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About this manual

The OrCAD Layout SmartRoute User’s Guide is intended to familiarize you with
SmartRoute’s autorouter and interactive routing capabilities.

To help you learn SmartRoute effectively, this manual covers the tasks you will
perform, beginning with the most basic tasks, and then progressing to more
advanced tasks. The appendices at the end of the manual address routing strategies
and troubleshooting techniques.

Before you begin

This manual assumes that you are familiar with Windows, that you have some
knowledge of printed circuit board design, and that you are familiar with OrCAD
Layout Plus. To learn about Layout Plus, read the OrCAD Layout User’s Guide and
read the numerous Layout online help topics.

Symbols and conventions

OrCAD printed documentation uses a few special symbols and conventions.

The keyboard

� The keys on your keyboard may not be labeled exactly as they are in this
manual. All key names are shown using small capital letters. For example, the
Control key is shown as CTRL; the Escape key is shown as ESC.

� Keys are frequently used in combinations or sequences. For example, SHIFT+F1
means to hold down the SHIFT key while pressing F1. ALT, F, A, means to press
and release each of these keys in order: first ALT, then F, then A.

� Arrow keys is the collective name for the UP ARROW, DOWN ARROW, LEFT

ARROW, and RIGHT ARROW keys.

� To choose a command from a menu, you can use the mouse or press a key
combination. For example: from the File menu, choose Open (ALT, F, O).
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Text

� Text you are instructed to type is shown in bold. For example, if the manual
instructs you to type *.max, you type an asterisk, a period, and the lowercase
letters max. The text you type is usually shown in lowercase letters, unless it
must be typed in uppercase letters to work properly.

� Placeholders for items such as filenames that you must supply are shown in
italic. For example, when the manual directs you to type cd directory_name,
you type the letters cd followed by a space and the name of a directory. For a
directory called CIRCUITS, you would type cd circuits.

� Examples of syntax and report output are displayed in monospace font—for
example: 17 74ALS163 U5,U6.
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About SmartRoute

Autorouters have two primary objectives: to route boards to 100% completion and to
route boards quickly. SmartRoute adds a third objective—quality of routing.

Historically, professional board designers have complained that autorouted boards
do not provide the same quality as manually routed boards. The side effects of
autorouting can include too many vias, tracks that wander, vertical layers with too
many horizontal segments and vice versa, unevenly spaced tracks, and more.

The most common complaint, however, is that autorouters usually route using an
X,Y orthogonal strategy. Experienced board designers instinctively route using
diagonals. Diagonal routing is more aesthetically pleasing and allows for more track
segments to be placed in an area. Consequently, the probability of finishing a more
difficult board is increased with diagonal routing.

This chapter examines the new technologies and time-proven methods that
SmartRoute uses to tackle autorouting quality issues.

Neural networks

A neural network is a subset of artificial intelligence. SmartRoute uses a neural
network for routing intelligence, and time and completion projection. It is among the
first CAD software products to employ artificial intelligence.

A neural network analyzes problems for which there is no explicit solution. Instead,
there may be a variety of solutions, some better than others. Consider an analogy.
There are a variety of ways a board can be routed, some of which are better than
others. The designer selects the best solution, considering all the options and
possible outcomes. This is also the function of the neural network and the other
neural utilities in SmartRoute: to provide intelligence that will result in the “best”
routing.
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While the concept of a neural network is relatively new to EDA, it is widely used
elsewhere. One of the better known uses is in the financial marketplace, where it is
used in analyzing and predicting stock market trends. Virtually every financial
institution involved in stock and currency trading uses neural networks as an
investment tool. Other areas where neural networks are used extensively are in
character recognition and speech recognition.

In order for a neural network to produce a solution, it must have input data
consisting of multiple sets of data similar to data describing the solution. The neural
network studies this historical data, a feature called “neural network training.” In the
case of financial analysis and prediction, where the solution is a prediction of stock
price, currency, index value, and so on, the input data is a time series of both the
financial item that is to be predicted, as well as a time series of related variables that
may have a relationship to the stock of interest. For example, to predict the closing
stock price of an electronic company tomorrow, you need 200-300 days of previous,
historical closing data on the stock, as well as 200-300 previous closing days of
other variables that you think might have a bearing on predicting the stock’s closing
value. These variables might be the Index of Electronics stocks, NYSE closing
prices on leading computer manufacturers’ stocks, and so on. Additionally, you
might want to include economic factors, such as the prime rate, the Eurodollar,
Dmark, Yen, and so on. Finally, and surprisingly, you might want to include some
seemingly unrelated variables, such as new housing starts.

The neural network analysis attempts to identify relationships among the various
variables and the item whose price is being predicted. A direct relationship such as
the price of crude oil and an oil company is obvious. An indirect relationship is not
as obvious—for example, the change in the closing price of a fast food chain and the
lower than average seasonal rainfall in the coffee-growing regions of South
America. The point is that in a relatively short period of time, a neural network can
find direct and indirect associations.

Just as a neural network for financial analysis requires training, the SmartRoute
neural network also required training. This training consisted of presenting to
SmartRoute a large number of routed boards that were routed interactively by
experienced, professional board designers. These boards contained examples of
every technology used today, such as single-layer, two-layer, multilayer, DIPS,
SMD, PGA, BGA, and so on, with the densities and sizes that are characteristic of
today’s packaging technologies.

The boards selected had all the characteristics associated with quality routing, such
as diagonal routing, primary direction by layer, minimum via count, minimized
wandering, and bus structure. These characteristics were used to establish neural
costs. The SmartRoute neural network determined the relationships between the
physical characteristics of these boards and the board being autorouted.

Appendix C includes a listing of suggested reading material for further information
on neural networks.
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Neural costs

All autorouters use a feature called cost for their routing algorithms. Cost determines
how difficult it is for the autorouter to perform a given activity. Using vias as an
example, on a scale of 1-100, a via cost of 1 makes it easy to install vias, and in the
absence of other costs, results in a board with many vias. A via cost of 100, on the
other hand, prevents the placement of vias, even in areas of the board where vias are
desirable.

Neural costs are not static; instead, they change dynamically throughout the routing
process. The neural costs are adapted in terms of routing completion. They are
adjusted as the board’s density changes due to routing. The dynamic adaptation of
cost applies for all cost-driven parameters.

A significant neural cost is connection sequencing, which controls the order in
which connections are selected for routing. Many autorouters use connection length
as the primary selection variable. SmartRoute, on the other hand, uses an advanced
sequencing cost that varies from board to board and takes the board’s connectivity
into account. Considerations also include the priority of nets, various patterns
requiring a specific routing order, busses, widths of tracks, and connection density.

Neural shapes

Shape-based routing has replaced gridded routing in today’s autorouters.
Conventional shapes provide immense advantages in routing speed and in routing
flexibility; however, conventional shapes and shape-based routing do not address
routing quality.

The SmartRoute neural shape concept successfully addresses the issue of routing
quality. Specifically, the SmartRoute neural shapes consist of polygons of all
different sizes and shapes. This, together with routing algorithms that permit X and
Y routing, 45° routing, and that are capable of selecting a routing direction by layer
from multiple choices (horizontal, vertical, 45° up, 45° down, 1 o’clock, 2 o’clock, 4
o’clock and 5 o’clock), provide the flexibility to enhance routing quality.

Routing algorithms (passes)

SmartRoute includes algorithms, called passes, for heuristic routing (a problem-
solving technique in which the most appropriate solution, of several found by
alternate methods, is selected in successive passes of the router), two-layer power
and ground routing, memory routing, fanout (dispersion) routing, several different
pattern routing algorithms, push-and-shove routing, and rip-up routing. All
algorithms are driven by neural cost and consider the connectivity of the board. In all
cases these algorithms, although traditional in the printed circuit board industry,
have been modified to meet the requirements of neural routing.
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Angled direction by layer

In SmartRoute, you can direct the autorouter to route in non-orthogonal directions
on each layer of a multilayer board.

The autorouter assigns a connection to a layer based on the user-assigned layer
direction and the connection’s slope or tangent. SmartRoute then routes the track
along the slant or approximate hypotenuse of a triangle, as opposed to routing
orthogonally along the X and Y legs of the hypotenuse. When routing using a
direction by layer:

� The approximate hypotenuse track length is shorter than the X and Y length.

� The board will have fewer vias.

Shorter track length provides more flexibility when placing parts. Combined with
fewer numbers of vias per connection, these considerations greatly accelerate the
routing process. Additionally, there is an increased probability of routing to 100%
completion.

The choice of which direction to use on each layer is entirely yours (although
SmartRoute initially assigns directions when it loads a board). In fact, the directions
may be limited to the conventional horizontal and vertical directions, if desired.
During the autorouting sequence, the autorouter selects the connections that most
nearly match each layer direction and routes the tracks in the selected direction on
that layer.

The figure below shows two layers of a six-layer board with layers routed at 45° up
and 45° down.

The basic movement uses long 45° diagonal segments with incremental orthogonal
steps that align the track’s direction with the selected layer direction.

   
  45o up (left), 45o down (right).
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Routing time, power, and quality

This section discusses routing time, power, and quality in autorouting.

Routing time

Routing time, historically, has been one of the prime criteria for evaluating
autorouters. But, the rapid evolution of both software and high-performance
hardware has de-emphasized the importance of routing time. For example, when
teamed with powerful PCs, a good autorouter should route nearly all six- to eight-
layer boards with 4,000-5,000 connections in about 5 to 15 hours.

Routing power

Routing power, or the ability to route close to 100% of the connections, has always
been extremely important in autorouting. And, it is even more important today.

Designers know that if an autorouter routes only 95% to 96% of the connections, the
time required to interactively complete the 4% to 5% of unrouted connections is as
great as the time it took to autoroute the first 95%. If an autorouter achieves only
90% to 93%, many designers will start over, routing interactively from scratch.

To help ease the frustration of routing the remaining few connections left by the
autorouter, SmartRoute uses contention routing. This allows the autorouter to route
connections (if necessary) regardless of spacing conflicts (or contentions) during the
initial routing pass. Then, SmartRoute removes the contentions in subsequent passes.
At the end of the autorouting sequence on an extremely dense board, there may
sometimes be a few contentions that will require interactive cleanup.

Is it better to have an unrouted connection, or a routed track with a contention?
Experienced designers prefer the track be routed with the contention rather than
being left unrouted. This is because the contention is normally confined only to one
area along the track, and it is easier to resolve a problem in one area than to make
room for an entirely unrouted connection.

Routing quality

Routing quality is somewhat different from routing time and routing power in that it
is evaluated in both subjective and objective terms; that is, you may consider
measurable criteria as well as aesthetic criteria when evaluating the quality of a
routed board. The measurable criteria include total number of vias, total amount of
copper (tracks), average track length, wandering or long tracks, violation of direction
by layer settings, absence of acute angles, and equal spacing of tracks between pads.
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Although difficult to measure, you will recognize quality routing when you see it.
The elements that define quality routing are as follows:

� A preference for 45° diagonal routing over X and Y orthogonal segments

� The ability to assign directions (other than X or Y) to different layers

� The collection of connections that bridge two areas or parts on the board into a
“bundle” of tracks, all using a similar track pattern

� A minimization of vias

� A minimization of wandering tracks

� Other features such as circuit flow

Predicting routing time and percent of completion

In SmartRoute, you can use the Analyze Parameters tool to predict routing time and
routing completion. The prediction is an estimate, which can be fairly close or wildly
inaccurate, depending on the complexity of the design. The more “average” the
board is, the more accurate the prediction. The prediction is most useful as a measure
of the effect of changing placements, spacing rules, and so on.

SmartRoute’s neural network is familiar with the standard boards used today: two-,
four-, six-, eight-, ten-, and sixteen-layer boards, through-hole, SMD top, SMD
bottom, fine-pitch SMD, and PGA. Additionally, the parameters (pad size, spacing,
via size, and so on) are based on the practices of skilled designers.

The neural network will not recognize boards in excess of 16 layers, 20" x 20", or
with unconventional design parameters, such as a 75 mils via or IC pad. You can
route these boards using SmartRoute, but the Analyze Parameters tool will not yield
accurate results.

O Note    In order for the Analyze Parameters tool to provide a more accurate
prediction of routing time, you must calibrate SmartRoute. For information on
calibrating SmartRoute, see Calibrating SmartRoute in Chapter 2: Getting started.
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Getting started

This chapter describes how to start SmartRoute. It also lists compatibility issues that
exist between Layout Plus and SmartRoute, and describes SmartRoute’s memory
requirements.

Calibrating SmartRoute

After installation, but before using SmartRoute, OrCAD recommends that you run
the calibration program. Calibration loads a board into SmartRoute and routes it.
From the length of time it takes to route this board on your system, SmartRoute can
assess your system’s impact on routing speed. Calibration significantly affects the
accuracy of the Analyze Parameters tool, which you can use to predict the routing
time and percentage of completion for a board.

& See also    For more information on the Analyze Parameters tool, see Analyzing
routing parameters in Chapter 5: Setting up the board for routing.

To calibrate SmartRoute

1 From the Windows Start menu, choose Programs.

2 Choose the OrCAD Design Desktop program group and then choose
SmartRoute Calibrate. SmartRoute opens and loads the calibration board, and
routes it.
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Starting SmartRoute

Start SmartRoute from the Layout Plus session frame.

M Caution    Starting SmartRoute by double-clicking on SROUTE.EXE opens
SmartRoute in demonstration mode and you cannot save your design.

To start SmartRoute

¬ From the Tools menu in the Layout Plus session frame, choose SmartRoute.

O Note    If you are running a version of Layout other than Layout Plus, the Tools
menu lists SmartRoute Demo instead of SmartRoute. In this case, you will only be
able to run SmartRoute in demonstration mode.

The SmartRoute session frame

Once you start SmartRoute, you see the SmartRoute session frame. This is the area
where the board is displayed.

The SmartRoute session frame.

Before you load a design, the title bar at the top of the session frame reads, “No
design file loaded.” When you open a design, that is replaced with the design’s
name. In SmartRoute, you can only open one design file at a time.

At the bottom of the session frame, you see the names of the seven routing passes
available for the autorouting sequence.

& See    For information on routing passes, see Specifying routing passes in Chapter
5: Setting up the board for routing.
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Compatibility with Layout Plus

The following Layout Plus features are not yet supported in SmartRoute:

� Display (dot) grid

� AutoPan

� Square vias

� Arcs in connections

� High-contrast mode

Memory

For general use, 32 MB of RAM is the recommended minimum amount of RAM.
For routing larger boards (four layers, 2,000 connections), more memory is
recommended. For boards with six or more routing layers and over 2,500
connections, a minimum of 64 MB of RAM is recommended.

SmartRoute uses about 10% to 15% more memory than other shape-based
autorouters. This additional memory is used to create the multi-sided neural shapes
that in turn permit the diagonal and angled routing that contributes to SmartRoute’s
high-quality routing.

If there is not enough memory in your system, the autorouter will not route. In the
event the autorouter will not route, check the SRTLOG.TXT file in the Layout Plus
directory for the message, “Not Enough Memory.”

If you receive this message, it may be possible to free up enough memory from other
applications. Although SmartRoute uses virtual memory, it will not run unless there
is enough available physical memory. To determine the amount of memory available
on your system, exit Windows and at the DOS prompt, type MEM.

On the line labeled Total Memory, examine the values for Total, Used, and Available.
If you have 32 MB on your PC, and if the value for Total is 32 MB, but the value for
Free is significantly less (5 to 6 MB), you can retrieve and use some of this memory.
To do so, determine where the additional memory is used and release it.

� If your CONFIG.SYS file has a “device” command for “RAMDRIVE,” it may
be using too much memory. Temporarily, reduce this amount by typing REM at
the beginning of the line. Reboot Windows. When you are done using
SmartRoute, you can restore your RAM drive to its original size.

� If your CONFIG.SYS or AUTOEXEC.BAT files load “SmartDrive,” it may be
using too much memory. Temporarily reduce this amount by typing REM at the
beginning of the line. Reboot Windows.

If these changes do not bring your available memory to within two or three
megabytes of active memory, something else is being loaded. Use a memory usage
utility to determine where the memory is being used, and then “free up” the memory.
Alternatively, you can purchase more memory.
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The SmartRoute work environment

This chapter describes the things you need to know to find your way around in
SmartRoute. It describes the functions of the pull-down menus and the pop-up
menus, explains what the information that is displayed in the status bar, and
discusses SmartRoute’s new user hints feature. It also discusses the zoom functions
and query tools used in SmartRoute.

SmartRoute menus

SmartRoute’s commands are located on pull-down and pop-up menus. SmartRoute
menus are active even when autorouting is in progress and the hourglass is active,
although some commands are dimmed and unavailable for selection during
autorouting.

The pull-down menus include File, Edit, View, Tool, Options, Auto, and Help. Their
functions are as follows:

File menu    The File menu includes commands for opening, closing, and saving
designs, as well as backup and restoration commands.

& See    For information on opening, closing, and saving designs, see Chapter 4:
Opening and saving designs.

Edit menu    The Edit menu includes the Undo and Redo commands, and a
Find/Goto command.

View menu    The View menu includes commands for viewing board density,
clearing and redrawing the screen, and various zooming commands.

& See    For information on zooming and searching in SmartRoute, see Viewing the
board in this chapter.

Tools menu    The Tools menu includes commands for highlighting and
identifying nets, identifying pins, sketching an approximate track for SmartRoute to
follow, and manually routing.
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Options menu    The Options menu includes routing setup commands, such as Net
Properties, Parameters, and Routing Passes. It also includes the Backup Interval
command, with which you can set the duration between automatic backups. There is
also a Batch Setup command for setting batch routing options, and the Hints
Checkbox command for enabling or disabling the SmartRoute new user hints
feature.

& See    For information on setting up the board for routing, see Chapter 5: Setting
up the board for routing. For information on using the new user hints feature, see
New user hints in this chapter.

Auto menu    The Auto menu includes commands for running the pre-route
synopsis and autorouting. It also includes commands for interactive and manual
routing.

& See    For information on autorouting and batch routing, see Chapter 6:
Autorouting and batch routing. For information on interactive and manual routing,
see Chapter 7: Editing the board.

Help menu    The Help menu provides access to the SmartRoute online help. The
SmartRoute online help provides a description of every command and dialog box in
SmartRoute, and includes key processes and reference information.

The Help menu also includes the About SmartRoute command, which displays the
version number, licensing, and copyright information for SmartRoute.

Pop-up menus

The SmartRoute pop-up menus provide easy access to frequently used commands.
You can display pop-up menus by pressing the right mouse button. The pop-up
menus provide commands that are appropriate for the current activity. For example,
during autorouting, the pop-up menu displays the commands Pause and Stop.
However, if the autorouter has been paused, the pop-up menu displays the
commands Restart and Stop.

6 Tip    During autorouting, SmartRoute displays an hourglass. Even when this
hourglass is displayed, you can still access menu commands and pop-up menu
commands, although some commands will be dimmed and unavailable for
selection.
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New user hints

A number of SmartRoute menu
commands provide a SmartRoute
feature called New User Hints. The
hints consist of command and dialog
box descriptions and tips. Use the hints
as a learning tool to help you become
familiar with SmartRoute. After you
have become familiar with SmartRoute
and no longer need the hints, you may
disable them individually, or all at
once. To disable one hint, select the
Click to turn off hint message option in the hint window, then choose the OK button.
To disable all hints, choose Hints Checkbox from the Options menu. In the dialog
box that displays, select the Turn Hints OFF option, then choose the OK button.

The status bar

The status bar, located at the bottom of the session frame, displays information
appropriate to the activity you are performing.

During autorouting, the status bar contains three levels of information. The top level
contains the names of the seven passes of the autorouting sequence. As routing
progresses, the pass that SmartRoute is currently executing is red. The middle level
is a red line that represents the progress of the current routing pass. The bottom line
provides a snapshot of the current routing status, such as the number of connections
routed, the percentage of the board that’s been routed, number of remaining
connections, number of vias, number of contentions, and total accumulated time on
the board, including both Layout Plus and SmartRoute activities.

For many commands, the status bar provides help tips. For example, when you
choose the Zoom In command, the status bar displays the following message:

Press and hold at center of zoom area.

After you press and hold the mouse button, the message changes:

Drag cursor to enclose zoom area.

When you release the mouse button, the status bar displays yet another message:

Select center of another zoom area.

The status bar can provide net and pin information too. When you choose the
Identify Net or Identify Pin commands, and select a net or a pin, the results of the
query display in the status bar. And finally, the status bar displays information about
SmartRoute’s current status, such as which task it is performing after you choose a
command.
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Viewing the board

In SmartRoute, you can easily view different areas of the board, get information
about specific pins and nets, and find parts, pads, and locations on the board. You
can also run a board density check using the Density Graph command.

Zoom functions

There are four commands in SmartRoute that you can use to change the view of the
board displayed on the screen: Zoom In, Zoom Out, Zoom Center, and Zoom All
(Fit).

� The Zoom In command magnifies a selected area of the board.

� The Zoom Out command increases the board area displayed.

� The Zoom Center command centers the selected area in the display.

� The Zoom All (Fit) command displays the entire board in the display.

To magnify an area of the board

1 From the View menu, choose Zoom In. The pointer becomes a “Z.”

2 Position the pointer at the upper left corner of the area that you want to magnify
and while pressing the left mouse button, drag the pointer to the opposite corner
of the area.

3 Release the left mouse button. The area is magnified.

4 Press the ESC key to exit zoom mode.

O Note    There may be a delay when you choose the Zoom In command, especially
if you are autorouting a very dense board, and the autorouter is currently routing a
long connection. In this case, the command will be performed when the current
connection is completed.

To view more of the board

1 From the View menu, choose Zoom Out. The pointer changes to a “Z.”

2 Place the pointer at the center of the area you want to view and click the left
mouse button.

3 Press the ESC key to exit zoom mode.
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To center an area of the board in the display

1 From the View menu, choose Zoom Center.

2 Position the pointer at the location you want to center in the display and click
the left mouse button. The selected area moves to the center of the display. The
scale remains unchanged.

3 Press the ESC key to exit zoom mode.

To view the whole board in the display

1 From the View menu, choose Zoom All (Fit). The entire board is displayed on
the screen.

2 Press the ESC key to exit zoom mode.

6 Tip    You can also use SmartRoute’s shortcut keys to change the current view of
the board. Press I to zoom in, press O to zoom out, or press Z to center the view
around your current pointer position.
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Displaying the board density

The Density Graph command displays an extremely accurate, color-coded, graphical
density map of the board, with red representing the hottest or most dense areas, and
blue representing the least dense.

The density graph considers unrouted connections, routed segments, and pads to
calculate density. It provides you with a detailed analysis of routing density due to
component placement.

When you are working with SmartRoute, you should use SmartRoute’s density
graph, rather than Layout Plus’s, because Layout Plus’s density graph is not
optimized to provide the information valuable to SmartRoute.

To display board density

¬ From the View menu, choose Density Graph. The color-coded density map
displays.

Use the following as a guide for evaluating the density map:

Best    The best board layouts display no red high-density areas. This is highly
desirable, but with high-density boards, not always possible.

Worst    It is difficult—perhaps impossible—to route a board with one or more very
large bright red areas, commonly referred to as “connection hot spots.” A large hot
spot could encompass 10% to 20% of the total board area. These are problem areas;
reposition components to reduce the density in these areas.

Compromise    It is virtually impossible to avoid hot spots when designing dense
boards. However, it is possible to reduce their impact. Several small hot spots are
better than one or two large hot spots. If you have large hot spots, return to Layout
Plus and, where possible, break up the large hot spots into smaller hot spots. Or,
reduce the density in the large hot spots.

To exit the density map

¬ From the View menu, choose Redraw Screen.
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Getting information

Use the Find/Goto command on the Edit menu, and the Highlight Net, Identify Net,
and Identify Pin commands on the Tools menu to locate or obtain information on the
nets and pins in the design.

To find a component, pad, or location on the board

1 From the Edit menu, choose Find/Goto. The Find dialog box displays.

2 Perform one of the following tasks:

� To find a part, enter the reference designator (for example, U9).

� To find a pad, enter the reference designator and pad number (for example,
U9.1).

� To find a location, enter its X and Y coordinates (for example, 4982, 5015).

3 Choose the Find button.

To highlight a net

1 From the Tools menu, choose Highlight Net. The Highlight Net dialog box
displays.

2 Select the net that you want to highlight.

3 Choose the Highlight button. All connections of the selected net are displayed in
the highlight color.

O Note    Highlighting a net is not persistent after a pan or zoom, and changing a
highlight value for any net in SmartRoute causes any previous highlights to be
turned off for all other nets.
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To turn off a net’s highlight

1 From the Tools menu, choose Highlight Net. The Highlight Net dialog box
displays.

2 Select the net for which you want to turn off the highlight.

3 Choose the End Highlight button.

To identify a net or pin

1 From the Tools menu, choose Identify Net or Identify Pin. The pointer changes
to a vertical arrow.

2 Select the desired net or pin. For a net, the connection length and net name are
displayed in the status bar. For a pin, the pin name is displayed in the status bar.

6 Tip     On large boards you may need to zoom in to select a net or pin to identify.
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C h a p t e r  4

Opening and saving designs

This chapter explains how to open designs (SmartRoute only reads Layout Plus
.MAX files), how to save them using the Save As and Backup Interval commands,
and how to close a design and exit SmartRoute.

Opening a design

You open Layout Plus .MAX files in SmartRoute using the Open command.

To open a design

1 From the File menu, choose Open. The Open Design File dialog box displays.

2 Locate and select a .MAX design file.

3 Choose the OK button.

6 Tip    The files that you have opened most recently are listed at the bottom of the
File menu. You can select files from this list to open them. This is the fastest way
to open designs that you have worked on recently.
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Saving a design

You save SmartRoute designs using the Save As command. You can also use the
Backup command to automatically save designs.

To save a design

1 From the File menu, choose Save As. The Save As dialog box displays.

2 To save a board under a new name, enter the name of the file, locate the target
directory, and choose the OK button.
or
To save the board under the same name, just choose the OK button. SmartRoute
asks you if you want to replace the existing file. Choose the Yes button.

O Note    There is no Save command in SmartRoute, only a Save As command.
However, you can use the Backup command to save a file without specifying a file
name. See Using backup in this chapter for more information.

Using backup

Three backup commands make up the SmartRoute backup feature: Backup, Restore
Backup, and Backup Interval. The Backup command automatically saves the design
and generates a file called SRBACK.RBK at the intervals you establish. Subsequent
backups overwrite the previous SRBACK.RBK. The advantage of backup is that, in
the event of power outages, hardware failure, or for whatever reason, you can go
back to an earlier sequence in the autorouting process. To open the last saved
version of the design, use the Restore Backup command.

To set the backup interval

1 From the Options menu, choose Backup Interval. The Auto Backup Interval
dialog box displays.

2 In the Make new backup every n minutes text box, enter the interval at which
you want SmartRoute to save the design and create the backup file,
SRBACK.RBK. If you enter 0 (zero) in this text box, you disable the backup
feature.

3 Choose the OK button.

6 Tip    OrCAD recommends setting backup intervals of 10 minutes.

O Note    Backup intervals reflect “real time.”
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To make a backup

¬ From the File menu, choose Backup. SmartRoute saves the file and replaces the
current version of the backup file, SRBACK.RBK.

To open the last saved SRBACK.RBK file

¬ From the File menu, choose Restore Backup. SmartRoute opens the current
backup file, SRBACK.RBK.

6 Tip    If you restore a board, you should immediately choose the Save As command
and save the file with the correct filename.

Closing a design and exiting SmartRoute

To close a design in SmartRoute, you must either open another design, or exit
SmartRoute (there is no Close command). For information on opening a design, see
Opening a design in this chapter.

To exit SmartRoute

¬ From the File menu, choose Exit. If there are unsaved changes in the design,
SmartRoute prompts you with the following three options. Select the desired
option.

Save and Exit    SmartRoute opens the Save As dialog box. Choose the OK
button. SmartRoute saves the design and exits.

Discard and Exit    SmartRoute discards the unsaved changes and exits.

Resume Program    This option cancels the Exit command.
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C h a p t e r  5

Setting up the board for routing

Setting up the board is the most important part of the routing process. There are
three items to consider when setting up the board for routing in SmartRoute: net
properties, parameters, and routing passes. When routing a board using SmartRoute,
the vast majority of setup activities are performed in Layout Plus. When you load the
board into SmartRoute, you are mainly concerned with checking the values
displayed to confirm that they reflect what you want.

This chapter describes each of the following in detail.

Net properties    Confirm, and change if desired, the net properties that you set in
Layout Plus, such as routing weight and track width.

Parameters    Confirm, and change if desired, various parameters used by the
autorouter, such as number of layers, direction of tracks on layers, pad sizes, and
more.

Routing passes    Select the routing passes that you want the autorouter to
perform during the autorouting process. OrCAD recommends that you use the
default passes set by SmartRoute.

O Note    In almost all cases, OrCAD recommends that you use the default values for
net properties, parameters, and routing passes in SmartRoute.
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Setting net properties

The first step in setting up the board for routing is to check the net properties that
SmartRoute received from Layout Plus. You can do this in the Net Properties dialog
box. The dialog box is organized like a spreadsheet. The names of all the nets in the
design are listed on the left side. A net name can be brought into view using either
the vertical scroll bar or by entering the net name in the Find Net text box at the
bottom of the dialog box. As you spell the name of the net, it is moved to the top of
the spreadsheet.

To change net properties in SmartRoute

1 From the Options menu, choose Net Properties. The Net Properties dialog box
displays.

2 Enter the name of the net that you want to view in the Find Net text box.

3 Modify the value for Routing Weight, Length Minimize, Route Action, or Track
Width by selecting a new value from the appropriate drop-down list. For a
detailed description of each option, read the dialog box option descriptions
below.

4 Choose the OK button.

O Note    OrCAD recommends that you use the net property values received from
Layout Plus.

Summary— All nets
in the database are
routed except for
VCC and GND,
which are fanned out
in the instance of
SMD components or
edge fingers
contained in the net.
The remaining nets
(through-hole parts)
do not need to be
fanned out, because
through-hole parts
connect to the plane.

Example    In this example, you modify the net properties for a four-layer board,
in which two layers (top and bottom) are used for routing signal connections, and
two planes are reserved for the power and ground nets. When signal connections
are to be routed, and power and ground are to be reserved for planes, set the power
(VCC) and ground (GND) nets as planes using the Route Action option in the Net
Properties dialog box.

1 In the Find Net text box, type GND to find the ground net.

2 In the Route Action column, note the available options. For this example, you
want the GND net to be fanned out (as for a plane); therefore, select the
Fanout/Plane option.

3 Repeat steps 1 and 2 for the VCC net.

4 Choose the OK button.
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The Net Properties dialog box

Routing Weight    Routing weight biases the order in which nets are routed. A
value of 100 assigns the highest priority for routing (the net will be routed sooner),
and a value of one, the lowest priority (the net will be routed later). This allows you
to route critical nets first. For example, you can assign a net with critical clock
speeds, or a net that is subject to interference, a higher priority to assure shorter
connection lengths.

Routing Weight allows you to select the order of routing. SmartRoute first selects all
nets with a weight of 81-100 that have unrouted segments, then attempts to route
them starting with the highest weight and the widest width.

It then selects all nets with a weight of 61-100 (including routed nets), and attempts
to route them starting with the highest weight and the widest width. During this pass,
it also attempts to remove conflicts from the routed nets.

Then, SmartRoute continues in the same manner with nets with a weight of 0-60. If
you don’t select a Routing Weight, the priority of routing is determined by the neural
network.

The Routing Weight values in SmartRoute reflect the values for weight set in Layout
Plus. You can change these values in SmartRoute. Keep in mind that slight
increments in the routing priority value have the same effect as dramatic increments.
For example, if all nets are given a routing priority of 50, and you change the routing
priority of one net to 51, the net set at 51 will be routed first. There is no need to set
that net’s routing priority to 90.
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Length Minimize    SmartRoute minimizes the lengths of the unrouted connections
on the board immediately before autorouting, in accordance with the Length
Minimize setting for each net. The setting options are described below.

None. No minimization occurs.

Min Dist (minimum distance). The connections are rearranged to result in a
minimum total length.

Daisy. The net retains the “from-to” sequence in the board design.

Horizontal. The connections in a net are rearranged to be horizontally biased. This
setting is primarily used for power and ground nets.

Vertical. The connections in a net are rearranged to be vertically biased. This setting
is primarily used for power and ground nets.

Route Action    The route action property provides the router with instructions for
routing a net.

Default. If a net is connected to SMD pads, and if there are no more than two routing
layers on the board, the net is routed without being fanned out from the SMD pad;
on a board with more than two routing layers, the net is fanned out, then routed.
Default is the normal mode for the autorouter and should not be changed unless for a
specific purpose.

Route. The system routes the net without a fanout.

No Route. The net is ignored by the autorouter.

Locked. When Locked is selected, the routed connections in the net cannot be
rerouted, pushed, or shoved. Partially routed connections may sometimes still be
shoved.

Fanout/Route. The net is fanned out from an SMD or edge finger pad, then routed.

Fanout/Plane. The net is fanned out from the edge finger or SMD pad but left in an
unrouted state (used for connecting to power and ground planes).

Track Width    The default entry is the primary track width as set in Layout Plus.
OrCAD recommends that you do not change this value, but if you wish to change it,
select a new width from the drop-down list.

If the width of a net is too thick to exit a pad, SmartRoute will use the net width
from a standard set of net widths in SROUTE.INI that is less than or equal to the
width of the pad. SmartRoute will not drop the width of the net lower than the
minimum width for the net specified in Layout Plus.

6 Tip    If you need a width that isn’t shown in the list, you can add it to
SROUTE.INI in the section Legal Track Widths.



Chapter 5    Setting up the board for routing

OrCAD Layout SmartRoute User’s Guide    27

Setting parameters

After the net properties have been set, set the design parameters. There are three
categories of parameters. They are all controlled in the Parameters dialog box.

� Layers

� Design parameters

� Analyze parameters

To change the parameters for routing

1 From the Options menu, choose Parameters. The Parameters dialog box
displays.

2 To bias the direction for routing on each layer, select the desired option from the
drop-down list adjacent to the layer name.

& See    For information on the layer options in the Parameters dialog box, see
Layers in this chapter.

3 Change the parameters for Units, Via Type, or Channel by selecting the
appropriate options from the drop-down lists.

4 Change the parameters for Primary Pad, Via Width, Primary Track, or
Clearance by typing new values in the text boxes.

O Note    OrCAD recommends that you set the parameter values in Layout Plus, and
then start SmartRoute. For more information on parameters, see Design parameters
in this chapter.

5 Choose the Analyze Parameters button. SmartRoute analyzes the effects of the
parameters that you set, and displays the results at the bottom of the dialog box.

& See    For information on using the Analyze Parameters tool, see Analyzing routing
parameters in this chapter.

6 When your parameter settings are as desired, choose the OK button.
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The Parameters dialog box

Layers

The Layers group box lists the copper layers as defined in Layout Plus. You can
select a direction in which routing will be biased for each layer. The choices are
listed below.

Best Choice    SmartRoute selects the direction for the layer.

Disabled    No routing occurs on the layer.

Fanout    The router will fanout vias on this layer but will not otherwise route on it.
Use this option when you wish to fanout the layer containing the SMD pads and also
restrict routing on that layer.

Plane    The layer is reserved for use as a plane layer upon its return to Layout Plus.
When this option is selected, the layer is no longer displayed in the Parameters
dialog box.

Vertical    The tracks are biased to be routed vertically.

Horizontal    The tracks are biased to be routed horizontally.

Any Direction    The router is not biased in any direction. The suggested use for
this option is on the third layer of a three-layer board. Do not use this option on more
than one layer.
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Angled options    Options include right and left 45° angles, 1 o’clock, 2 o’clock, 4
o’clock, and 5 o’clock angles. These options will bias the layer in the direction
selected. The options may be used for all layers on a multilayer board, although top
and bottom layers are usually horizontally or vertically biased. These options are
usually used by board designers to achieve shorter track lengths and fewer vias.
These options can only be used on multilayer boards.

Summary— While it is
a good practice to set
up the layers in Layout
Plus prior to starting
SmartRoute, it is
possible to modify the
layer routing direction
bias inside
SmartRoute.

Example    In this example, you are routing the top and bottom layers and
reserving layers 2 and 3 for planes. This means that during routing, tracks are not
placed on layers 2 and 3. Also, the design, loaded as a four-layer board from Layout
Plus, is returned to Layout Plus with layers 2 and 3 reserved for plane activity.

1 From the Options menu, choose Parameters. The Parameters dialog box
displays.

2 For layer 2, select Plane. Layer 2 is reserved for use as a plane layer.

3 For layer 3, select Plane. Layer 3 is reserved for use as a plane layer.

4 For the top layer, select Horizontal from the drop-down list. The top layer of
the board will be routed with a horizontal bias.

5 For the bottom layer, select Vertical from the drop-down list. The bottom
layer of the board will be routed with a vertical bias.

Design parameters

Parameters are read directly from Layout Plus. In the Parameters dialog box, you can
check the parameters you set in Layout Plus—including units, pad and via width,
track width, and clearance—to make sure they display as you expect.

Before the new parameter settings are accepted in SmartRoute, you must choose the
OK button in the Parameters dialog box and respond to the questions that display.
The answers you provide confirm your decision to modify parameters before the
changes are accepted by SmartRoute.

O Note    Always check the Primary Pad, Via Width, Primary Track, and Clearance
parameters to make sure that the values displayed are what you would expect from
Layout Plus.

The design parameter options are described below.

Units    From the drop-down list, select the desired data structure units for
autorouting. OrCAD recommends that you use the same unit structure that you used
in Layout Plus.

Via Type    From the drop-down list, select the type of vias that you want to use on
your board.
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Channel    In SmartRoute, the channel size that displays is automatically calculated
by SmartRoute for your board. To calculate this value, SmartRoute adds the most
frequently used track width on the board and the most common track-to-track
clearance on the board. SmartRoute then selects the channel value that is closest to
that sum (equal to or greater than—it does not round down) from the standard list of
SmartRoute channel sizes listed in the SROUTE.INI file. This value reflects the
optimum routing channel size for your board.

O Note    Channel size may not be exactly the same as the system grid specified in
Layout Plus; channel size is calculated independently by SmartRoute using the
primary track width and clearance parameter values in Layout Plus. For example, if
you are routing a board with 12 mils tracks and 13 mils clearance, SmartRoute sets
the routing channel to 25 mils.

OrCAD strongly recommends that you use the default channel size calculated by
SmartRoute. When you return to Layout Plus, the system grid value will reflect the
channel size selected by SmartRoute. If you have different grid requirements, you
must change the system grid in Layout Plus.

O Note    Note that if you change the Primary Track value or spacing rules, channel
size is recalculated after you choose the OK button in the Parameters dialog box.

SmartRoute is a gridless router. It will try to place tracks on the channel specified,
but on dense boards this may not be possible. Therefore, changing the channel
value for a dense board may have little effect on routing in SmartRoute.

Primary Pad    The Primary Pad option displays the diameter width of the most
commonly used pad on the board. If there are no through-hole pads, the Primary Pad
option displays the width of the largest SMD pad.

For instance, on a board with 1000 pads from 50 components of various sizes, there
could be 20 different pad sizes and shapes. The most common pad shape and size is
displayed for the Primary Pad option.

Via Width    The via width is the same as the first via defined in Layout Plus.
SmartRoute, however, will choose the best via size for a given situation when
routing.

Primary Track    The primary track width is the routing width of the majority of
the nets as defined in Layout Plus. If there are multiple track widths on a board (for
example, all signal widths are 12 mils, and all power and ground widths are 50 mils),
the primary track width would be 12 mils, if there are a greater number of signal
connections than there are power and ground connections.

Clearance    The Clearance option specifies the spacing required between tracks
(track-to-track clearance). This value is defined in Layout Plus.
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Analyzing routing parameters

The Analyze Parameters feature is unique to SmartRoute. With this feature, you can
estimate the routing time and percentage of route completion for the active board
using the current parameters.

Furthermore, you can conduct “what if” exercises with the parameter settings, trying
a number of different configurations. The Analyze Parameters option estimates the
settings’ effect on routing time and routing success.

The more “average” the board is, the more accurate the prediction of routing time
and completion for the board. The prediction may be off by varying degrees. It is
most useful as a measure of the effect of changing placements, spacing rules, and so
on.

To analyze the selected parameters effect on routing

1 From the Options menu, choose Parameters. The Parameters dialog box
displays.

2 Choose the Analyze Parameters button. The estimated time and completion for
the board display at the bottom of the dialog box.

3 When you are finished, choose the OK button.

Specifying routing passes

In the Routing Passes dialog box, you can enable various routing passes that will be
used during the autorouting sequence, as well as set options for manufacturing.

OrCAD strongly recommends that you run all the passes using the default routing
pass setup without modification. However, there are some instances in which only
one or more of the routing passes should be activated.

� You have a very dense SMD board and you are not sure that all of the pads will
be fanned out (with the current placement). In this situation, select only Fan Out
Used SMD Pins and deselect the other routing passes. When you autoroute the
board, only the Fan Out Used SMD Pins routing pass is performed. Fanout
failures are marked with a small yellow circle with an X in the center. If there
are many failures, you should change the placement on the board.

� You have a true memory bank on your board and you are concerned with where
it should be placed and how the components should be oriented. In this
situation, select only the Memory routing pass to evaluate the memory pattern.

Before the routing passes are run, SmartRoute analyzes the board. During this phase,
the board is scanned and the appropriate neural costs are applied by the neural
network. Once this is finished, the specified routing passes are performed.
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To specify routing passes

1 From the Options menu, choose Routing Passes. The Routing Passes dialog box
displays.

2 Ensure that the passes you want to run during autorouting are selected, then
choose the OK button.

O Note    During autorouting, the status bar contains three levels of information about
the routing passes. The top level contains the names of the seven passes of the
autorouting sequence. As routing progresses, the pass that SmartRoute is currently
executing is red. The next level is a red line that represents the progress of the
current routing pass. The third level is the text that displays beneath the red line.
This text provides information about the status of the autorouting sequence.

Summary— On very
dense SMD boards,
run the fanout routing
pass alone before
autorouting with all of
the passes. If you
experience more than
10% fanout failure,
adjust placement in
Layout Plus.
Otherwise, autoroute
the board using all of
the available routing
passes.

Example    In this example, you are routing a very dense four-layer SMD board.
You need to run Fan Out Used SMD Pins first. If you have less than 10% fanout
failure, you can autoroute the board.

1 From the Options menu, choose Routing Passes. The Routing Passes dialog
box displays.

2 Select the Fan Out Used SMD Pins option and deselect all other routing passes
in the dialog box, then choose the OK button.

3 From the Auto menu, choose AutoRoute Board. SmartRoute performs fanout.

4 Check the board to see that you have less than 10% fanout failure. A failure is
indicated by a small yellow circle with an X in the center.

� If so, open the Routing Passes dialog box. Select all of the routing passes.
Autoroute the board.

� If the board has more than 10% fanout failure, go back to Layout Plus and
adjust placement to lessen the density in the areas in which the failures
occurred, then bring the board back into SmartRoute.
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The Routing Passes dialog box

The routing passes are described below.

Memory    This routing pass routes all memory or memory-like nets on the board.
This pass is heuristic; it searches for nets that can be routed using one of several
simple patterns. OrCAD recommends that you run it even though you may not have
actual memory on the board.

Fan Out Used SMD Pins    This pass is used to fanout vias from SMD or edge
finger components. The fanout via that is usually used is a conventional through-
hole via. The fanout via can change, depending on the density of the area being
routed. If the autorouter does not have enough space for a via, it will switch to a
smaller one.

The fanout pass is both heuristic and search. It should always be used if there are
single-sided components on the top layer or bottom layer of the board. When a via
fails to fanout, a small yellow circle with an X in the center displays on the board.

O Note    Very dense boards with SMD parts on top and bottom layers may have
difficulty during fanout. OrCAD suggests that you make a “trial” run with only the
Fan Out Used SMD Pins option selected in the Routing Passes dialog box before
you commit the board to the total autorouting sequence. If you find that the router
cannot implement fanout for a significant number of the total number of pins (about
10%) scheduled for fanout, it is highly likely that 100% completion will not be
achieved. In this case, you should adjust the placement of the components in the
areas of the board where the fanout failures occurred.

Pattern    The pattern routing pass uses a collection of different strategies, each
addressing a particular type of pattern. The router searches the board for such
patterns and routes them using the appropriate pattern strategy. OrCAD recommends
that you always use this pass.
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Push N’ Shove     The push n’ shove routing pass is the most powerful routing pass
in SmartRoute. It pushes and shoves existing tracks out of the way in order to make
room for new tracks. It routes on a diagonal. It has no limits on how far it can push
other tracks, and can jump over vias and pads.

Ripup    Upon completion of the push n’ shove routing pass, there may be spacing
violations, or contentions on the board (contentions appear as small yellow circles).
Generally, subsequent passes of the various routing passes remove the contentions.
In very dense boards, however, contentions may persist after all the previous passes
are completed. The ripup routing pass is then used to unroute the routed tracks
associated with the contentions and reroute them, eliminating the problem. The
number of contentions displays in the status bar interactively as routing progresses.
For more information about contentions, see Contention in this chapter.

Contention

The term contention is a relatively new term in autorouting vocabulary. All the
routing passes in SmartRoute are based on contention routing. That is, it is
permissible for the autorouter to place a track or via so that it creates a spacing
violation (contention) with other tracks, vias, and pads.

Some examples of routing contention include:

� A track segment crossing a track segment of a different net

� A track segment being placed on top of a track segment of another net

� A track segment that violates space requirements with an existing via or pad

� A via that violates space requirements with another via, pad, or track segment

When a contention is created, a small yellow circle approximately 0.1" in diameter
(hollow) is created at the point of contention. It remains until the contention is
cleared. Subsequent routing passes attempt to remove the contention by either
pushing or rerouting the track that caused the contention, or by pushing or rerouting
the existing track. If there is not enough room to push or reroute a track to eliminate
the contention, the contention remains and must be fixed by manual routing, or fixed
in Layout Plus.

The number of contentions displays in the status bar. During routing, the number of
yellow circles (contentions) on the board may differ from the number shown in the
status bar. This is due to the fact that the screen is updated instantly as a connection
is routed, whereas the data line is updated only after a major routing pass.

6 Tip    If there are still unrouted nets or contentions after routing, they may be
completed by another combination of push n’ shove and ripup passes.
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Manufacturing passes

The manufacturing passes are described below.

O Note    As routing occurs, via minimization and segment count minimization are
performed by the router automatically. As a result, a separate via minimization pass
does not exist.

To specify manufacturing passes

1 From the Options menu, choose Routing Passes. The Routing Passes dialog box
displays.

2 If you have already routed the board, deselect all of the routing passes and select
the manufacturing passes that you wish to run.
or
If you want to run the manufacturing passes during routing, select the desired
passes listed in the dialog box and choose the OK button.

3 From the Auto menu, choose Autoroute Board. SmartRoute runs the selected
passes.

Evenly Space Tracks    This pass is used to evenly space tracks between other
tracks or pads. When only one track is routed between two pads, it may be placed on
a 20 mils channel near one or the other of the IC pads. Running the Evenly Space
Tracks manufacturing pass shifts this track to the center of the space between the IC
pads.

Track Corners    Use this feature to choose either orthogonal or mitered corners.
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C h a p t e r  6

Autorouting and batch routing

This chapter discusses the autorouting and batch routing processes. It describes how
to run a pre-route synopsis, how to start, stop, pause, and restart the autorouter, and
how to run batch routing. It also guides you through the routing of a two-layer and a
four-layer board.

& See    For information on setting up the board for routing, see Chapter 5: Setting
up the board for routing. It is essential that you set up the board properly, to ensure
routing success.

Autorouting

After checking the net properties and parameters, selecting routing passes, and
running the pre-route synopsis, you can perform autorouting. The autorouting
process consists of the sequential resolution of the routing passes that you select in
the Routing Passes dialog box. When SmartRoute is satisfied that it has completed
all possible connections using that pass, it moves on to the next specified routing
pass.

You can suspend routing temporarily using the Pause AutoRouter command on the
Auto menu. To restart the routing from where it left off, choose the Restart
AutoRouter command from the Auto menu. If you want to stop the autorouting
process, choose the Stop Autorouter command from the Auto menu. (If you choose
the Stop AutoRouter command, you must choose the AutoRoute command of your
choice to restart the autorouter, which begins at the first enabled pass again.)

M Caution    Occasionally after the autorouter is started, and the Analyze Board pass
is completed, the autorouter stops and displays this message:

One or more connections cannot be routed…

The Analyze Board routing pass checks for critical problems in your design
(problems that may result in an unusable board). The autorouter stops so that you
can correct the problem before proceeding. The error can be identified by
examining the file SROUTE.LOG. Usually the problem involves a pad and its
location in relation to another pad, the board outline, or other obstacle.

You should correct the condition in Layout Plus (if necessary) and proceed.



Chapter 6    Autorouting and batch routing

38    OrCAD Layout SmartRoute User’s Guide

Pre-route synopsis

The pre-route synopsis is a report that gives you complete details of the various
parameters of the design, as well as how you have set up the routing passes that the
autorouter will use. Use it immediately after you have set up the autorouter, but
before you start routing. Using the pre-route synopsis, you can preview all of the
necessary settings for the router, and if they are not set properly, you can fix them
before routing to save time.

To run the pre-route synopsis

1 From the Auto menu, choose Pre-Route Synopsis.

2 Review the data in the report that displays, then close the report.

Running the autorouter

The first routing pass in the autorouting sequence is called Analyze Board. This
process involves SmartRoute’s neural network (discussed in Chapter 1: About
SmartRoute). The neural network studies the various parameters and characteristics
of the board and compares them to those it was trained with. The bigger the board,
the longer the Analyze Board pass takes. A small, unrouted board may spend about
90 seconds on this pass. A large, multilayer, routed board may spend two to four
minutes on this pass. The Analyze Board pass creates a neural map and selects a
neural cost file.

Following the Analyze Board pass, the autorouter progresses sequentially through
the routing passes specified in the Routing Passes dialog box. You can observe the
following during autorouting:

� The fanout of edge finger connectors and SMD pins during the Fan Out Used
SMD Pins pass.

� The routing of the memory array on the board during the Memory pass.

� The remaining signal connections on the board are routed with a combination of
orthogonal and diagonal segments.

� Although the power and ground nets are fanned out from the I/O connector,
they are not routed.

During routing, the three levels of the status bar provide information about the
autorouter’s status.

� The top level contains the names of the seven passes of the autorouting
sequence. As routing progresses, the pass that SmartRoute is currently executing
is red.

� The middle level is a red line that represents the percentage of completion.
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� The bottom level provides a snapshot of the current routing status, such as the
number of connections routed, the percentage of the board that’s been routed,
number of unrouted connections, number of vias, number of contentions,
routing time, and total accumulated time on the board, including both Layout
Plus and SmartRoute activities. With the exception of number of contentions,
this is a real-time display and alleviates the need for pausing the autorouter for
detailed information.

O Note    The number of contentions displays in the status bar. During routing, the
number of yellow circles (contentions) on the board may differ from the number
shown in the status bar. This is due to the fact that the screen is updated instantly as
a connection is routed, whereas the data line is updated only after a major routing
pass.

To autoroute the board

¬ From the Auto menu, choose AutoRoute Board. SmartRoute initiates the
autorouting sequence specified in the Routing Passes dialog box.

O Note    As the router progresses, tracks may display small, jagged steps.
SmartRoute automatically runs a pass that cleans up tracks and minimizes vias
during routing.

To pause the autorouter

¬ From the Auto menu, choose Pause AutoRouter. SmartRoute temporarily
suspends the autorouting sequence.

O Note    To restart the autorouter, choose Restart AutoRouter from the Auto menu.
SmartRoute restarts the routing process from the point at which it paused.

To stop the autorouter

¬ From the Auto menu, choose Stop AutoRouter. SmartRoute ends the
autorouting sequence.

O Note    To restart the routing sequence, choose the autoroute command of your
choice from the Auto menu. SmartRoute starts again at the first enabled routing
pass.

6 Tip    During autorouting, SmartRoute displays an hourglass. Even when this
hourglass is displayed, you can still access menu commands and pop-up menu
commands.
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Batch routing

Batch commands are used to establish a list of different boards to be autorouted
without operator intervention. For example, using batch routing you can route
multiple boards overnight. Batch routing consists of two steps:

� Selecting files to add to the queue for batch routing

� Starting the batch route operation

When the batch sequence is complete, SmartRoute produces and displays the report
SROUTE.LOG that provides the details from the batch routing process. If the router
fails on any design in the sequence, it skips on to the next board and displays the
error in SROUTE.LOG.

6 Tip    If you only want the output for the current batch run, delete the existing
SROUTE.LOG before you start the batch routing.

To perform batch routing

1 From the Options menu, choose Batch Setup. The Batch Design File dialog box
displays.

2 Locate and select the file that you want to add to the batch queue and choose the
OK button. The Save Routed Design File As dialog box displays.

3 In the File Name text box, enter a name and select the target directory for the
post-route file, then choose the OK button.

4 Repeat steps 1 through 3 for each file that you want to add to the queue.

5 When you are ready to start the batch operation, choose AutoRoute Batch from
the Auto menu. The Start Batch dialog box displays. It lists all the files in the
queue for batch routing. Any files listed will be routed during batch routing.

6 Select and delete any files that you do not want to include in the batch
operation.

7 Choose the OK button to start batch routing. SmartRoute routes each design in
sequence. SmartRoute displays SROUTE.LOG.
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Setting up and routing two-layer boards

On a two-layer board, signal, power, and ground connections are routed on two
routing layers, without using planes. When routing a two-layer board, check that the
layer settings in the Net Properties dialog box are correct. Most importantly, in the
Net Properties dialog box, set the Route Action for power and ground nets (VCC
and GND) to Route (not Fanout/Plane as with multilayer boards).

SmartRoute has a power and ground router that creates an optimum pattern for
power and ground nets. This pattern attempts to place the power and ground tracks
inside the row of pins of an IC on the layer coincident with the direction of the IC
major axis.

For example, consider a board on which the ICs are vertically biased, the top layer is
horizontally biased, and the bottom layer is vertically biased. Power and ground will
be placed on the bottom layer and will run vertically inside the rows of pins on each
IC. The top layer will contain horizontal tracks that connect together the vertical
tracks inside the rows of IC power and ground.

To set up and route a two-layer board

1 From the Options menu, choose Net Properties. The Net Properties dialog box
displays.

2 Find the power net and change the Route Action option to Route. Repeat this
step for the ground net, then choose the OK button.

& See also    For more information on setting net properties, see Chapter 5: Setting
up the board for routing.

3 From the Options menu, choose Parameters. The Parameters dialog box
displays.

4 Check the layer settings to ensure that the top layer displays with a horizontal
bias, and the bottom layer displays with a vertical bias, then choose the OK
button.

& See also    For more information on setting parameters, and on using the Analyze
Parameters option, see Chapter 5: Setting up the board for routing.

5 From the Auto menu, choose Pre-Route Synopsis and examine the report.

& See also    For more information on running the pre-route synopsis, see Pre-route
synopsis in this chapter.

6 Close the report, then choose AutoRoute Board from the Auto menu. The power
and ground tracks are routed, along with the signal connections on the two
layers.
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In the LAYOUT\SAMPLES\DEMOSR directory, there is a two-layer board set up
for this function: BOARD2.MAX. It may be helpful to experiment with this board.
Set the parameters for BOARD2.MAX as follows:

� Via Width: 0.055

� Primary Pad: 0.06

� Primary Track: .012

� Clearance: 0.013

� Top layer: Horizontal

� Bottom layer: Vertical

Setting up and routing multilayer boards

The objectives of this section are to demonstrate multilayer (more than two layers)
routing, and the concept of “direction by layer.”

The step-by-step instructions tell you how to set up and route an eight-layer SMD
board with four routing layers and four planes. The components are all SMD parts
and are located on both the top and bottom layers of the board.

For this exercise, use BOARD3.MAX in the LAYOUT\SAMPLES\DEMOSR
directory. Once you have opened the board file, set up the net properties so that the
signal connections will be routed and the power and ground connections will be
reserved for planes. The process below shows you how.

To set the net properties for an eight-layer board

1 From the File menu, choose Open. The Open Design File dialog box displays.

2 Go to the LAYOUT\SAMPLES\DEMOSR directory, select BOARD3.MAX,
and choose the OK button.

3 From the Options menu, choose Net Properties. The Net Properties dialog box
displays.

4 The plane nets for BOARD3.MAX are GND, GND1, VDD, and VDD1. Find
each plane net (by typing its name into the Find Net text box at the bottom of
the dialog box), and set its Route Action option to Fanout/Plane. The Route
Action option for the remaining nets (signals) should be set to Default.

5 Choose the OK button.
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Setting up the layers

SmartRoute provides you with two different approaches for setting up the direction
in which routing is biased on each layer.

Orthogonal routing    If routing speed is of primary importance, select a direction
by layer using either horizontal or vertical on all routing layers. For example, for
four routing layers, use horizontal, vertical, horizontal, vertical, or vertical,
horizontal, vertical, horizontal.

The primary direction by layer will be either horizontal or vertical, but the router
will use both diagonal and horizontal and vertical segments The routing time will be
somewhat less than it would be using a primary direction that is not either horizontal
or vertical.

Angled direction by layer    If routing speed is not a major consideration for you,
you can use angled direction by layer. Angled direction by layer results in shorter
tracks and fewer vias. It can route tracks in a combination of angles: 45° up, 45°
down, 1 o’clock, 2 o’clock, 4 o’clock and 5 o’clock. For example, on a four-layer
board, you may choose to use vertical, 45° up, 45° down, and horizontal.

The first of the next two processes emphasizes routing speed using vertical and
horizontal routing. The second process demonstrates angled direction by layer. You
can use BOARD3.MAX in the LAYOUT\SAMPLES\DEMOSR directory for this
operation.

To set up the board for horizontal and vertical routing

1 From the Options menu, choose Parameters. The Parameters dialog box
displays.

2 Set the four routing layers (top, bottom, inner1, and inner2) as Vertical,
Horizontal, Vertical, Horizontal by selecting the appropriate options from the
drop-down lists. Then, if they are listed in the dialog box, set the other four
layers to Plane (once set to plane, the layers no longer display in the dialog
box). Check the other parameter settings in the dialog box and choose the OK
button.

3 From the Options menu, choose Routing Passes. The Routing Passes dialog box
displays.

4 Ensure that all of the routing passes are selected, and select the Mitered option
for the Track Corners manufacturing pass. Choose the OK button.

5 From the Auto menu, choose Pre-Route Synopsis. Review the report to ensure
that the database parameters are as you would expect, then close the report.

6 From the Auto menu, choose AutoRoute Board. Observe the autorouter during
the routing process.
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To set up the board for routing using angled directions by layer

1 From the Options menu, choose Parameters. The Parameters dialog box
displays.

2 Set the routing layers as follows:

� Top: vertical

� Bottom: 45° up

� Inner1: 45° down

� Inner2: horizontal

Then, if they are listed in the dialog box, set the other four layers to Plane (once
set to plane, the layers no longer display in the dialog box). Check the other
parameter settings in the dialog box, then choose the OK button.

3 From the Options menu, choose Routing Passes. The Routing Passes dialog box
displays.

4 Ensure that all of the routing passes are selected, and select the Mitered option
from the Track Corners manufacturing pass. Choose the OK button.

5 From the Auto menu, choose Pre-Route Synopsis. Review the report to ensure
that the design parameters are as you would expect, then close the report.

6 From the Auto menu, choose AutoRoute Board. Observe the autorouter during
the routing process.

Routing with angled direction by layer has important advantages, including fewer
vias, shorter track length, and higher completion percentage. In addition, it facilitates
interactive editing.

Note that SmartRoute will choose the directions for angled routing if you don’t
specify them. Use the following as a guide for angled routing for four- and six-layer
boards.

Four routing layers Six routing layers

Top Horizontal or vertical Horizontal or vertical

Inner 1 45° up, 1 o’clock, or
2 o’clock

Inner 2 45° down, 4 o’clock, or
5 o’clock

For all inner layers on a board with
six routing layers:

45° up/down, 1 o’clock,
2 o’clock, 4 o’clock, or 5 o’clock

Bottom Horizontal or vertical
(different from top)

Horizontal or vertical
(different from top)

O Note    Do not use all 45° up and 45° down; use a mix of 45° and clock angles.
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C h a p t e r  7

Editing the board

You can use the interactive and manual routing commands on the Auto and Tool
menus to manually route areas of the board, and for general board editing. Use these
commands when you want more control over the routing process than is possible
with the autorouter. For example, with the interactive and manual routing commands
you can:

� Autoroute individual connections, defined areas, or the connections associated
with a single component.

� Draw a path for the autorouter to follow using SketchATrack.

� Route a track manually under design rule check (DRC) supervision that alerts
you to spacing violations, but permits violations if you concur.

� Unroute the entire board, a net, a connection, or a single segment.

When using the interactive and manual routing commands, SmartRoute features
multi-level Undo and Redo commands.

The Undo command reverses the last action taken, and has unlimited levels, from the
last time you saved the design. For example, if you manually route a horizontal
segment, then route a diagonal segment, and choose the Undo command, the result
of the diagonal routing is returned to its previous state. If you choose Undo again,
the result of the horizontal segment is returned to its previous state.

The Redo command reverses the actions of the Undo command.
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Interactive routing

There are four interactive routing commands that are actually autorouting commands
that route only portions of the board. They are AutoRoute Area, AutoRoute
Component, AutoRoute Net, and AutoRoute One.

AutoRoute Area

The AutoRoute Area command routes a selected area on the board.

To autoroute a selected area on the board

1 From the Auto menu, choose AutoRoute Area. The pointer becomes a vertical
arrow.

2 Pressing the left mouse button, drag the pointer to select the area to be routed.
All connections starting or ending in the designated area are routed.

AutoRoute Component

Use the AutoRoute Component command to route all of the connections originating
or ending on a pin of a component. Note that within a net, only the connections
starting or ending on the selected component will be routed.

To autoroute the connections originating or ending on a pin of a
component

1 From the Auto menu, choose AutoRoute Component. The pointer becomes a
vertical arrow.

2 Select a component. The connections starting or ending on a pin on the
component are automatically routed.

AutoRoute Net

Using the AutoRoute Net command, you can route all of the connections associated
with a net.

To autoroute the connections associated with a net

1 From the Auto menu, choose AutoRoute Net. The pointer becomes a vertical
arrow.

2 Select a connection within the net. All of the connections within that net are
routed.
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AutoRoute One

The AutoRoute One command autoroutes one connection at a time.

To autoroute one connection

1 From the Auto menu, choose AutoRoute One. The pointer becomes a vertical
arrow.

2 Place the pointer over any connection to be routed and click the left mouse
button.

3 Repeat step 2 for each connection that you want to route.
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SketchATrack routing

Using the SketchATrack command, you can sketch a suggested path and the
autorouter routes the connection, approximately matching the path you have
sketched. When you route pin-to-pin, the autorouter attempts to take the midpoint
between the IC pad rows and the most direct path. For multi-connection nets, it is
possible to route from a pin to a track, rather than from a pin to a pin.

The layer that is automatically selected by the SketchATrack command is
determined by the direction you sketch from the start pin. The shorter the track, the
more successfully the autorouter will match the line you draw. Long, curvy lines are
not followed as closely.

The length of a routed connection displays in the status bar during routing. For
example, the entry “U13.12 to U6.6 4.325 $$$ 1348” indicates that the connection
between the listed pins of net $$$1348 is 4.325 inches in length.

To route a track using the SketchATrack command

1 From the Tools menu, choose SketchATrack.

2 Select the connection that you want to sketch. The connection, its first and last
pins, and the complete net are highlighted.

3 Press the left mouse button and drag the mouse to draw the desired path.

4 Release the left mouse button. The autorouter routes the connection to the point
where you release the button.

5 Press and drag again to continue drawing the connection to the end pin. When
you’ve sketched a track close enough to the end pin, SmartRoute completes the
connection.

To delete a sketched track

¬ To erase part of a sketch, loop the sketched track back over itself at the point
where the deletion is to occur.

To change layers while using SketchATrack

¬ After selecting the connection, type the number that corresponds to the desired
layer.
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To create vias while using SketchATrack

1 Sketch the track to the desired via location.

2 Release the left mouse button.

3 Type the number that corresponds to the target layer. SmartRoute changes
layers (the appropriate color for the target layer displays).

4 Complete the track on the target layer.

To modify segments using SketchATrack

1 Select the point at which you want to begin to modify the segment with the left
mouse button. The connection and its pins are highlighted.

2 Press the left mouse button and drag the mouse to create the new path.

3 Release the left mouse button at the point at which you want to stop modifying
the segment. The autorouter erases the segment of the routed track and attempts
to reroute it along the new, modified track.

To draw circuitous paths using SketchATrack

¬ Sketch the desired roundabout path in short, straight increments, releasing the
mouse button as you complete each segment. SmartRoute autoroutes the path to
each point in turn, eventually creating the desired track.
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Manual routing

You can use the commands on the Tools menu to manually route areas of the board,
and for general board editing.

The Manual Route command offers the most control over routing. The Manual
Route command does not use the SmartRoute autorouter. Instead, you drag the track
along the intended path in a completely interactive fashion. SmartRoute’s automatic
design rule check (DRC) alerts you to spacing violations by displaying small yellow
circles. Because SmartRoute allows contentions to exist on the board, you can
choose to ignore the violations.

To manually route a track in SmartRoute

1 From the Tools menu, choose Manual Route.

2 Position the pointer over the first pin or connection line and click the left mouse
button to select the connection.

3 Move the pointer toward the target pad. A dashed line in the color of the active
layer displays.

4 To create a corner, click the left mouse button. Then continue drawing by
moving the pointer in the desired direction. The new segment can be either
orthogonal or diagonal.

5 To insert a via, move the pointer to the desired location and type the number
that corresponds to the target layer. A via symbol (white circle) is placed at the
location and the target layer is displayed. If the via symbol is not displayed
immediately, it will be displayed after the next corner is placed, or after
choosing Finish from the pop-up menu.

6 To delete the last portion of track that was routed, choose the Undo command
from the pop-up menu.

7 To complete the track at its end pin or on another routed track, position the
pointer very near the center of the pad or track and click the left mouse button.

8 To stop manual routing, choose Exit from the pop-up menu.
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Deleting routes

In SmartRoute, it is possible to unroute routed tracks using five commands on the
Auto menu. You have several levels of routing deletion to choose from:

Unroute Board    Use the Unroute Board command to delete all routing on the
entire board, even tracks that were routed in Layout Plus (including locked
preroutes), or in previous SmartRoute sessions. When you choose this command,
SmartRoute prompts you to make sure that you really want to unroute all of the nets
on the board. This command cannot be undone using the Undo command.

Unroute Net    Use the Unroute Net command to unroute one routed net. To do so,
choose the Unroute Net command from the Auto menu and select the net that you
want to unroute.

Unroute Connection    Use the Unroute Connection command to unroute one
connection (a connection is an unrouted net that connects two pads). To do so,
choose the Unroute Connection command from the Auto menu and select the
connection that you want to unroute.

Unroute Segment    Use the Unroute Segment command to unroute one segment
of a connection or net (a segment is the track between two vertices). To do so,
choose the Unroute Segment command from the Auto menu and select the segment
that you want to unroute.

Unroute Conflicts    Use the Unroute Conflicts command to unroute all tracks that
are in contention, so that you can reroute them. When SmartRoute is finished
unrouting these tracks, the number of connections that were unrouted displays in the
status bar.

& See    For information on contention, see Contention in Chapter 5: Setting up the
board.
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Appendix A

Design checklist and common errors

In preparing a Layout Plus file for SmartRoute, it is not uncommon to find
unexpected design criteria violations, which can be catastrophic. If the autorouter
does not detect the errors, it may spend a considerable amount of time routing the
board—yet the results will be unusable.

In order to prevent such a situation, SmartRoute reads and writes Layout Plus files
directly. During this process, SmartRoute searches for design rule errors. Typical
design rule errors include a connected component pad overlapping (“shorting out”) a
component pad of a second component (thus tying two nets together), or a connected
component pad to which a thick track is attached. If this component pad is too close
to a different net, it creates a space violation.

These design rule errors are not detected during the loading process. Instead, they
are detected at the time the autorouter is started. If violations are detected, the
autorouting process stops and a message displays. In this situation, examine
SROUTE.LOG for the offending error and correct it.

O Note    In most designs with design rule errors, the errors can be detected in Layout
Plus, before loading the design into SmartRoute. From Layout Plus’s Auto menu,
choose Design Rule Check, select all the options in the Check Design Rules dialog
box that displays, then choose the OK button.

Another worthwhile design check to perform in Layout Plus is to display all items
on the board (i.e., component pads, board outline, connections, copper, and so on)
and visually inspect them for obvious errors, such as connected pads outside the
board outline.
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Use the following checklist as a guide for avoiding design errors in SmartRoute.

� Do not try to subdivide plane layers with copper, outlines, or details until after
routing.

� Avoid placing copper lines, outlines, or details on routing layers in an attempt to
restrict routing to the areas created.

� Copper area obstacles may be placed on routing layers for the purpose of
prohibiting SmartRoute from placing tracks or vias in the area defined by the
copper. Note that SmartRoute maintains spacing around text on copper layers.

� Route keepout obstacles may be placed on routing layers for the purpose of
prohibiting the placement of routes in the area defined by the obstacle.

� Component pads outside the board outline to which connections are attached
will be rejected. Hence, before attempting to load a board design into
SmartRoute, visually inspect your design in Layout Plus. (Unconnected pads
outside the board outline are acceptable.)

� A design must have a complete, closed board outline. A design without a board
outline or with a partial outline is not valid.

� When creating the board outline, always use the Board Outline obstacle type in
Layout Plus, and place it on the global layer.

� There cannot be more than one board outline in the design.

� Obstacles on routing layers are potential problems. When creating obstacles on
routing layers in Layout Plus, ensure they do not “short out” pads in different
nets.

� Leave enough room between obstacles and connected pads to avoid spacing
violations during routing.

� When placing components, leave enough clearance between connected pads and
the board outline to avoid spacing violations during routing. Edge finger
connections are a frequent offender in this category.

� If you add mounting holes to a layered board, SmartRoute will ignore the drill
on the inner layers. Consequently, in Layout Plus you must define a pad in the
Padstacks spreadsheet for the internal layers. The presence of even a 1 mil pad
will cause SmartRoute to observe the drill size for the mounting hole.



OrCAD Layout SmartRoute User’s Guide    55

Appendix B

Solving routing problems

With the right set of parameters and enough physical space to route the connections,
SmartRoute will achieve 100% completion. There are times, however, when this
does not happen. Use this appendix to analyze routing problems and correct them.

The autorouter has stopped, the time counter has stopped, or the autorouter is
not advancing

The most likely cause is an inadequate amount of physical RAM in your CPU.
SmartRoute’s autorouter uses a variety of shapes—triangles, rectangles, pentagons,
and others. These multi-cornered shapes require more memory for constructing a
routing map than the conventional shapes used by other shape-based routers.

The benefits of using these shapes are diagonal segments and quality routing; the
cost is 10-15% more RAM.

The following is an approximate guide to RAM requirements for SmartRoute.

Board characteristics Available memory requirements

Two to four routing layers, up to 1000
connections

~16 MB

Six routing layers, up to 1500
connections

~32 MB

Six to eight routing layers, up to 3500
connections

~48 MB

SmartRoute memory requirements.
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The autorouter is too slow

OrCAD recommends that you run SmartRoute on a Pentium-class computer.

Router achieves low percentage (i.e., 75-85%) completion

There could be many reasons. Check the following:

� If routing a previously routed multilayer board with power planes, check to
ensure that the copper used to construct the power planes in the original board
design has been deleted. If the power plane is still covered with copper,
SmartRoute cannot penetrate the copper in order to put in a via.

� The circuit density (number of connections) is far in excess of that which will fit
on the area and number of routing layers selected for routing.

Upon returning to Layout Plus, a design rule check of the routed board finds
errors

Most likely you changed the parameters (primary pad, via width, primary track, or
clearance) in the Parameters dialog box in SmartRoute and used these new
parameters during autorouting. You must manually set the new parameters in Layout
Plus.

Also, if there are unresolved contentions in SmartRoute, they are flagged as errors in
Layout Plus.

& See    For a description of the options available in the Parameters dialog box, see
Setting parameters in Chapter 5: Setting up the board for routing.

SmartRoute displays the following message: LOW RESOURCES

You may encounter this message while performing activities such as board editing.
You will not encounter it during autorouting. This is the result of the combination of
the board’s characteristics and the editing having prevented some memory from
being realized. A few occurrences are not of concern. However, if it happens several
times (6 to 8), you should clear your computer’s memory by saving the .MAX file
(using SmartRoute’s Save As command), exiting all programs, and restarting
Windows.

If you are routing a board that is near the limit of available memory, and you have
noticed this “Low Resources” message two or three times, you may want to clear
your computer’s memory prior to autorouting.
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The router seems slow when routing angled layers

This is true. Routing a multilayer board using horizontal and vertical routing is faster
than routing with a combination of horizontal, vertical, and angled tracks. It is more
difficult and time consuming to push and shove a segment on an angle than it is to
push and shove a segment either horizontally or vertically.

An approximate guide for estimating the additional time is to add approximately
15% per angled layer over the time estimated for horizontal and vertical routing. For
example, if routing a four-layer board using horizontal and vertical routing took one
hour, then routing horizontal/45°, up/45°, down/vertical, would take about 1 hour 20
minutes.

Only a few connections or contentions are left unrouted

Generally, you will find that upon completion of routing, the results fall into one of
three categories.

� 100% routed.

� 10-20% unrouted. Clearly a major problem exists in this situation. There is
probably a mismatch among the area of the board, the number of routing layers,
and the number of connections to be routed.

� 1-2% or less of the connections left unrouted. In this situation, follow the
procedures below to achieve 100% routing. When followed, these procedures
may prove to be successful in routing those final few connections.

Parameter review

Review the parameters to ensure that they are complementary. For example, a 55
mils via with 6 mils track and 6 mils clearance is a mismatch (the via is
inappropriately large for the track size) that will greatly handicap the autorouter on a
dense board. Use the following as a guide when selecting parameters.

Tracks/Clearance (mils) Pads/Through-hole Pads SMD Vias

12/13 55-60 24 55-60

10/10 50-55 24 55-60

8/8 50 24 35-40

6/6 48-50 24 30-35

Fine Pitch SMD

6/6 48-50 10 28-35

Design and manufacture parameter guidelines.
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Component placement

Assuming the parameter settings are reasonable and the board can indeed be routed,
it may be necessary to adjust part placement. SmartRoute has three excellent aids for
use in evaluating placement:

� Density graph

� Analyze parameters

� Area or component autoroute

& See    For information on component placement strategies, see Component
placement strategies in this appendix.

Density graph    SmartRoute’s density map (accessible from the View menu) is
extremely accurate and can be useful in identifying problem areas. The colors of the
density map vary from blue (low-density) to bright red (high-density). This density
map is the primary indicator of routing order. Use the following as a guide for use in
evaluating the density map.

Best. The best board layouts display no red high-density areas. This is highly
desirable but with high-density boards, not always possible.

Worst. Do not attempt to route a board with one or more very large bright red areas,
commonly referred to as “connection hot spots.” A large hot spot would encompass
10-20% of the total board area. These are problem areas; reposition components to
reduce the density in these areas.

Compromise. It is virtually impossible to avoid hot spots when designing dense
boards. However, it is possible to reduce their impact.

Note that several small hot spots are better than one or two large hot spots. If you
have large hot spots, return to Layout Plus and, where possible, break up the large
hot spots into smaller hot spots. Or, reduce the density in the large hot spots.

Analyze parameters    The Analyze Parameters feature is unique to SmartRoute.
With this feature, you can estimate the routing time and percentage of route
completion for the active board using the current parameters.

With this feature, you can conduct “what if” exercises with the parameter settings,
trying a number of different configurations. The Analyze Parameters option
estimates the settings’ effect on routing time and routing success.

However, if you use non-standard parameters (for example, oversize via pads of
0.075) the accuracy of the prediction may be degraded.
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AutoRoute Area and AutoRoute Component    The AutoRoute Area
command is extremely useful for routing dense areas on the board. Routing dense
areas using this command is fast and effective. You may find that all the connections
within the area can be routed without contentions. By routing the densest areas in
this manner, you can increase your chances of routing 100% of the board.

Routing components in dense areas using the AutoRoute Component command
achieves similar results. In addition to using these commands, use the strategies
described in Component placement strategies in this appendix.

Component placement strategies

The following guide will assist you in placing individual parts.

Routing channel

While placing the parts in Layout Plus, place parts on the routing channel (grid
setting) that SmartRoute will use. Calculate this value by adding the track size and
the clearance values in Layout Plus. The following are suggested channels:

Track clearance (mils) Suggested routing grid (mils)

12/13
12/12

25

10/10 20

8/8 16 2/3

6/6 12.5

Track clearance and suggested routing grids.

Do not block routing channels

Place parts so that their pads align with the pads of other parts in both the X and Y
direction.
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SMD spacing
SMD pads on different parts must be separated sufficiently to allow for fanout. The
separation must consider the fanout via diameter, track length, size of the part
(number of pins), how heavily connected the part is, and the presence of top and
bottom layer SMD pads occupying the same space. Use the following table as a
guide for achieving adequate SMD separation.

Board characteristics Fanout allocation

Small SMD (16-20 pins), lightly
connected

One or two rows of fanout vias
between parts

Medium SMD, heavily connected Minimum of two rows of fanout vias

Large SMD (>150 pins), heavily
connected

Three to four rows of fanout vias

Large SMD (>150 pins), heavily
connected. SMD parts on the top and
bottom layers.

Six or more rows of fanout vias

Very large fine pitch SMD (>150 pins),
heavily connected. Parts on both the
top and bottom layers in same area.

Eight or more rows of fanout vias

Suggested fanout allocations.

The above assumes two things about the fanout router:

� It can fanout vias to both the outside and inside of the SMD component.

� It has both heuristic (simple pattern algorithms) and search capabilities that can
find a fanout via when necessary.

SMD location on top and bottom layers

In today’s high-density designs, the SMDs on both top and bottom layers may be
large, and can be in excess of 300 pins.

The previous section discussed the spacing between SMD parts on a layer. You must
also consider the relationship between parts on different layers. To maximize the
board area available for fanout vias, place components on the bottom layer directly
under components on the top layer. In effect, the pads on the top layer superimpose
themselves over the pads on the bottom layer.

If possible, similarly sized parts should be reflected on the top and bottom layers. In
other words, a 100-pin SMD part on the bottom layer should be aligned with a 100-
pin part on the top layer. When you must place a 100-pin, four-sided part on the
bottom layer under a 200-pin, four-sided part on the top layer, line up one corner and
the two associated sides. Furthermore, two-pin, discrete parts on the bottom layer
should be located directly under SMD IC parts on the top layer.
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To evaluate a suspect layer for fanout problems, open the Routing Passes dialog box,
turn off all routing passes except for Fan Out Used SMD Pins, then choose the OK
button. Next, use the AutoRoute Area command to autoroute the area of concern.
Examine the results for fanout failure—indicated by small yellow circles. If there is
in excess of 5-8% fanout failures, as compared to the total number of fanouts (after
all five fanout passes), adjust component placement in this area.

More tips and tricks

� Before loading designs created with Layout Plus versions earlier than v7.10, for
routing in SmartRoute, open them in Layout Plus and save them with a new
name. This will give you a backup copy of the design. Loading and saving
designs also updates the design so that SmartRoute can work with it more
efficiently.

� Fanout is not as effectively controlled in SmartRoute as it is in Layout Plus. You
cannot tell the router to go only to the interior or exterior of a component, nor
can you specify whether to share fanout vias or not (SmartRoute is share only).

� If there are unrouted connections, or there are contentions after autorouting, try
disabling the fanout, memory, and pattern routing passes, and running the
autorouter again.

& See    For information on enabling or disabling routing passes, see Specifying
routing passes in Chapter 5: Setting up the board for routing.

� If you get an “out of memory” error when your board is nearly routed, it may be
possible to finish the routing process. Save the design, reload it, and run the
routing process again. To save time, turn off the fanout, memory, and pattern
routing passes.

� If the status bar in SmartRoute reports that there are contentions on the board
after routing, run Design Rule Check in Layout Plus. From Layout Plus’s Auto
menu, choose Design Rule Check. In the Check Design Rules dialog box that
displays, select the Route Spacing Violations option, then choose the OK
button.

� Occasionally, within the first ten minutes of autorouting, SmartRoute reports the
following error:

Routing Problem encountered. Attempt auto-resume?

If you answer Yes, the program attempts to restart. But, if upon restarting, the
message displays again immediately, SmartRoute is caught in an infinite loop,
and answering Yes to restart SmartRoute again will only perpetuate the cycle. If
you answer No, the autorouter stops.
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I n d e x

A
algorithms, routing, 3, 23, 31, 33

Fan Out Used SMD Pins, 31, 33
Memory, 33
Pattern, 33
Push N’ Shove, 34
Ripup, 34

Analyze Parameters feature, 31, 58
Analyze Parameters routing pass, 37
angled direction by layer, 43, 44
arcs, 9
area, routing, 46, 59
Auto Backup Interval dialog box, 20
Auto menu, 12
AutoRoute Area command, 46, 59
AutoRoute Batch command, 40
AutoRoute Component command, 46, 59
AutoRoute Net command, 46
AutoRoute One command, 47
autorouting, 37–39

autorouter stopped, 55
batch routing, 40
completion percentage, 56, 57
multilayer boards, 42–44
slow, 56, 57
speed of, 56, 57
two-layer boards, 41

B
backing up your design, 20
Backup Interval command, 20
batch autorouting, 40
Batch Design File dialog box, 40
board density, 16, 58, 59
board outlines, 54

C
center board, 14
changing layers, 48
Channel parameter, 30
channels, 30, 59
clearance, 30
Clearance parameter, 30
closing designs, 21
commands

AutoRoute Area, 46, 59
AutoRoute Batch, 40
AutoRoute Component, 46, 59
AutoRoute Net, 46
AutoRoute One, 47
Backup Interval, 20
Density Graph, 16, 58
Exit, 21
Find/Goto, 17
Highlight Net, 17
Hints Checkbox, 13
Identify Net, 17
Identify Pin, 17
Manual Route, 50
Net Properties, 24
Open, 19
Parameters, 27
Pause AutoRouter, 37
Pre-Route Synopsis, 37, 38
Redo, 45
Restart AutoRouter, 37
Routing Passes, 32
Save As, 20
SketchATrack, 48, 49
Stop AutoRouter, 37
Undo, 45
Unroute Board, 51
Unroute Conflicts, 51
Unroute Connection, 51
Unroute Net, 51
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Unroute Segment, 51
Zoom All (Fit), 14
Zoom Center, 14
Zoom In, 14
Zoom Out, 14

completion percentage, 56, 57
component placement, analysis, 58, 59
components

finding, 17
pads outside board outline, 54
placing, 58–61
routing all connections of, 46
spacing, 60

connection hot spots, 16
connections

arcs in, 9
routing single, 47

contention, 34, 57
routing, 5

copper areas, 54
costs

in autorouters, 3
neural cost, 3
via costs, 3

D
data, routing, 13
deleting tracks, 48, 51
density, 58, 59
Density Graph command, 16, 58
design preparation checklist, 53
design rule check, 45, 56
designs

backup, 20
closing, 21
opening, 19
parameters, 23
preparation checklist, 53
saving, 20
units, 29

dialog boxes
Backup Interval, 20
Batch Design File, 40
Hints, 13
Open Design File, 19
Parameters, 27, 28
Routing Passes, 32, 33

Save As, 20
Save Routed Design File As, 40
Start Batch, 40

direction by layer, 43, 44
dividing plane layers, 54
drawing circuitous paths, 49

E
edge finger connections, 54
Edit menu, 11
Exit command, 21
exiting SmartRoute, 21

F–G
Fan Out Used SMD Pins routing pass, 31, 33
fanout, 31, 33

plane, 26
route, 26

File menu, 11
files

MAX, 20
SRBACK.RBK, 20

Find/Goto command, 17

H
Help menu, 12
Highlight Net command, 17
Hints Checkbox command, 13
Hints dialog box, 13
hints, new user, 13
horizontal routing, 28
hot spots, 16

I–K
Identify Net command, 17
Identify Pin command, 17
information, routing, 13
interactive routing, 45–49, 59
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L
layers, routing direction by, 28
Layout Plus, compatibility with, 9
length of nets, 26
location on board, finding, 17
locking nets, 26
low resources, 56

M
magnify board, 14
Manual Route command, 50
manual routing, 50
manufacturing passes

Evenly Space Tracks, 35
Track Corners, 35

MAX files
closing, 21
opening, 19
saving, 20

memory requirements, 9, 55, 56
Memory routing pass, 33
menus

Auto, 12
Edit, 11
File, 11
Help, 12
Options, 12
pop-up, 12
Tool, 11
View, 11

minimize net length, 26
minimum width, 26
mitered corners, 35
modifying segments, 49
multilayer boards, routing, 42–44

N
Net Properties command, 24
nets

order for routing, 25
priority for routing, 25
properties, 21–26
routing, 46
width, 26

network, neural, 1
neural

costs, 3
network, 1
shapes, 3

new user hints, 13

O
obstacles, 54
Open command, 19
Open Design File dialog box, 19
opening designs, 19
Options menu, 12
order, routing, 25
orthogonal

corners, 35
routing, 43

P–Q
pads

outside board outline, 54
primary, 30
width, 30

parameters, 23, 27
guidelines, 57
layers, 28

Parameters command, 27
Parameters dialog box, 27, 28
passes

manufacturing
Evenly Space Tracks, 35
Track Corners, 35

routing, 3, 23, 31, 33
Fan Out Used SMD Pins, 31, 33
Memory, 33
Pattern, 33
Push N’ Shove, 34
Ripup, 34

Pattern routing pass, 33
Pause AutoRouter command, 37
pins, finding, 17
placing components, strategies, 58–61
planes

dividing, 54
layers, 26
nets, 26

pop-up menus, 12
power, for routing, 5
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predicting routing time, 31, 58
preparing designs for routing, 53
Pre-Route Synopsis command, 37, 38
primary pad, 30
Primary Pad parameter, 30
Primary Track parameter, 30
priority, routing, 25
problems

design preparation checklist, 53
routing, 55, 56

properties
Length Minimize, 24, 26
net, 23, 21–26
Route Action, 24, 26
Routing Weight, 24, 25
Track Width, 24, 26

Push N’ Shove routing pass, 34

R
RAM requirements, 55
reading, suggested, 63
Redo, 45
reference material, 63
requirements, memory, 9
Restart AutoRouter command, 37
restricted areas, 54
Ripup routing pass, 34
Route Action

Fanout/Plane, 26
Fanout/Route, 26
Locked, 26
No Route, 26
Route, 26

route keepouts, 54
routing

a selected area, 46, 59
algorithms, 3, 31, 33
autorouting, 37–39
batch autorouting, 40
channels, 30, 59
completion percentage, 56, 57
components, 46
connections, 47
contention, 5
deleting tracks, 48, 51
direction by layer, 4, 28, 43, 44
interactive, 45–49, 59

manual, 50
multilayer boards, 42–44
net properties, 23
nets, 26, 46
non-orthogonal, 4
order, 25
orthogonal, 43
parameters, 23
passes, 3, 31, 33
percentage of completion, predicting, 6, 31, 58
power, 5
predicting routing time, 31, 58
problems, 55, 56
quality, 1, 5
reversal, 51
spacing, 56
status, 13
time, 5, 31
tips and tricks, 61
troubleshooting, 55, 56
two-layer boards, 41
using SketchATrack, 48

routing passes, 23
Analyze Parameters, 37
Fan Out Used SMD Pins, 31, 33
Memory, 33
Pattern, 33
Push N’ Shove, 34
Ripup, 34

Routing Passes command, 32
Routing Passes dialog box, 32, 33
Routing Weight property, 25

S
Save As command, 20
Save As dialog box, 20
Save Routed Design File As dialog box, 40
saving designs, 20
screen, in SmartRoute, 8, 13
session frame, 8
shape-based routing, 3, 55
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SketchATrack
changing layers, 48
circuitous paths, 49
command, 48, 49
creating vias, 49
deleting tracks, 48
modifying segments, 49

slow, autorouter, 56, 57
SmartRoute

exiting, 21
menus, 11, 12

spacing, 60
problems, 56
tracks, 35
violations, 54

speed of autorouter, 56, 57
SROUTE.LOG, 37, 40, 53
Start Batch dialog box, 40
status bar, 13
Stop AutoRouter command, 37
stopped, autorouter, 55
strategies

placing components, 59
routing, 61

subdividing plane layers, 54
suggested reading, 63
system requirements, 9, 55, 56

T
text, 54
time counter stopped, 55
time, for routing, 5
tips

for routing, 61
new user, 13

Tool menu, 11
tracks

deleting, 48, 51
spacing, 35
unrouting, 51
width, 26, 30

troubleshooting
design preparation checklist, 53
routing, 55, 56

two-layer boards, routing, 41

U
Undo, 45
units, 29
Units parameter, 29, 30
Unroute Board command, 51
Unroute Conflicts command, 51
Unroute Connection command, 51
Unroute Net command, 51
Unroute Segment command, 51
unrouted connections, 56, 57
unrouting tracks, 51
user hints, 13

V
vertical routing, 28
Via Type parameter, 29
Via Width parameter, 30
vias, 49

minimization, 6
no via zones, 9
square, 9
types, 29
width, 30

view board, 14
View menu, 11

W–X
widths

nets, 26
pads, 30
tracks, 26, 30
vias, 30

Y
yellow circles, 34

Z
Zoom All (Fit) command, 14
Zoom Center command, 14
Zoom In command, 14
Zoom Out command, 14
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