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Introduccio

En aquest seminari es fa servir la darrera versié d’avaluacioé gratuita del programa OrCAD
Capture que és la versio 16.3 Demo. De tot I'entorn de disseny, es fara us de la part relativa
a la introduccié d’esquematics i al PSPICE per simular i analitzar els nostres circuits
electronics.

Aquesta versio del programa ja esta instal-lada en els ordinadors del laboratori docent i
també pot aconseguir-se descarregant-la de Ila pagina web de Cadence
(http://www.cadence.com/products/orcad/pages/downloads.aspx).

Objectiu

L’objectiu d’aquesta sessio és que els estudiants es comencin a familiaritzar amb I'Us
d’aquest software de simulacio. Per assolir aquest objectiu aquesta sessio esta organitzada
en forma de tutorial.

Passos a seguir en una simulacié d’un circuit electronic

Les simulacions de circuits electronics amb PSPICE consten de 5 passos importants:
1) Creacio d’'un nou projecte i un nou esquematic.

També hi hauria la l'alternativa d’especificar el circuit en forma de netlist perd, en
general sera més practic fer-ho amb el capturador d’esquematics.

2) Introducci6 de I'esquematic del circuit triant els components, connectant-los i
especificant els seus valors.

3) Creacio d’'una simulacio6 i especificacié dels seus parametres.
4) Execucio de la simulacié.

5) Visualitzacio dels resultats.

Com es crea un nou projecte?

El primer que cal fer és executar el programa de la seguent forma:

Inicio > Todos los programas > Cadence> Release 16.3 > OrCad Capture

La pantalla de I'ordinador hauria d’aparéixer de la forma de la Figura 1:
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Figura 1

El seglent pas és crear un nou projecte seleccionant com mostra la Figura 2:

File > New > Project

¥ OrCAD Capture CIS - Demo Edition
ZL8 View Tools Edit Options Window Help

New [ Project.. | - 1

Open 4 Design m
B Save Chrl+ S Library

Save As.. VHDL File
Verilog File

Text File

Print Preview...
Print... Ctrl+P
Print Setup...

Import Design...
Export Design...

1 Practica 1 SULTRA.opj
2 C\Users\..\orcad\prova.opj

Change Product...

Exit

Figura 2

Aquest menu fa obrir la finestra de dialeg de la Figura 3 on s’ha de triar I'opcié “Analog or
Mixed A/D”, s’ha de donar un nom al projecte i s’ha d’especificar el directori on es vol
guardar. Doneu-li el nom circuitRC i guardeu-lo en una carpeta a la vostra zona d’usuari
mitjangant la tecla “Browse”. Un cop realitzat s’ha de clickar 'OK.
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Figura 3

En la seguent finestra de dialeg, Figura 4, s’ha de triar I'opcié per generar un projecte nou
“Create a blank project”.

(©) Creats based upon an existing project

Analog& NDSymbol opi

® Creale a blank project

Figura 4

Finalment, dins de la finestra de 'OrCad Capture apareixen dues finestres tal com es mostra
en la Figura 5. La finestra del davant correspon a la finestra de captura d’esquematics i la
del darrere és l'estructura del projecte amb tots els fitxers del disseny. Per treballar més
comodament a I'hora de dibuixar el circuit, heu de maximitzar la finestra de captura
d’esquematics.

En la finestra principal també es poden veure les barres de menus que disposa el programa
per accedir a les funcions i opcions principals: barra Capture, barra Draw i barra Pspice. En
I’Annex d’aquest document es detallen algunes de les principals opcions d’aquestes barres
de mendus.
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Barra PSPICE
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Figura 5

Com es seleccionen, es connecten i s’especifiquen els
components del circuit?

Un cop oberta la finestra de captura d’esquematics ja es pot comencar a dibuixar el circuit
que es vol simular.

Per seleccionar els components que volem dibuixar podem fer Us o bé del menu principal
“Place” de la part superior de la pantalla o bé de la barra de menus que apareix al marge
dret de la pantalla. Les dues formes son equivalents. Aquest menu disposa de bastants
opcions o icones de les quals, de moment, només n’utilitzarem unes quantes.

Com a primer exemple dibuixarem i simularem un simple circuit RC com el de la Figura 6.

R,
+
1k Q
Vv, 1orF v,
1V G
Figura 6
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La primera consideracié important és que PSPICE calcula els valors de les tensions en els
nodes del circuit referides a un potencial comd (massa o “Ground”). Per tant, si no
s’especifica aquest node de referéncia, la simulacié dona un error que el sistema detalla
com que hi ha nodes flotants (“floating”). Per tant, comengarem per afegir el node de
referéncia seleccionant del menu principal:

5
Place > Ground - |
1
O bé, clickant l'icona de massa del menu Draw del marge dret de la pantalla 5
(Figura 7).
1
En la finestra de dialeg que s’obre triarem “0/SOURCE?” i clickarem “OK”. ’j’
Place Ground - &I‘ L
-
0/CAPSYM ﬁ
0/D es\En Cache -
GND/CAPSYM — 0
GHD_EARTHICEPS M — bx
.
=%
Name:
0 .
Figura 7
Use 0/CAPSYM symbol to place a de ground

Figura 8

I amb el ratoli podem moure la massa del circuit per situar-la en el lloc que desitgem. Podem
dibuixar tants punts de massa com vulguem posicionant el cursor en el lloc desitjat i clickant
el botd esquerre del ratoli. En el circuit d’exemple en necessitem dos ja que volem connectar
a massa tant la font de tensié com el condensador. Per sortir de la seleccid, cal polsar el
boto dret del ratoli i triar 'opcié “End Mode”, o bé fer “Esc” des del teclat.
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Figura 9

El seglent pas és dibuixar els components electronics. Heu de seleccionar:

Place > Part
O bé, heu de clickar l'icona & del menu Draw del marge dret de la pantalla. Aquesta

seleccid fa obrir la finestra “Place Part” al marge dret de la pantalla com es mostra en la
Figura 10.
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Figura 10

En aquest punt necessitem afegir al nostre disseny les llibreries que inclouen els elements
que conté el circuit que volem simular. PSPICE disposa de gran multitud de llibreries que
corresponen als dispositius electronics utilitzats en la practica. Inclds en el cas de dispositius
meés especifics, es poden descarregar les llibreries i models des de la pagina web del seu
fabricant. Per afegir una llibreria cal clickar sobre l'icona o “Add Library” que obre la
finestra de dialeg de la Figura 11.

Buscar en: pspice - @3 m-
T Nembre . Fecha modificacién  Tipo Tam: *
Y 81| 7400.0lb 17/08/2009 1741  OrCAD Capture C..
Sitios recientes ) 2pm ol 18/08/2009 223 OrCAD Capture C..
! 8| ad_reg.olb 13/10/2009 12:32 QrCAD Capture C...
\B] adv_lin.olb 17/08/2009 17:41 OrCAD Capture C...
Escritorio \B| ana_swit.olb 17/08/2009 17:41 OrCAD Capture C..,
:T-\ |Hl| analog.olb 01/09/2009 12:09 OrCAD Capture C...
Wi 8| analog_p.olb 18/08/2009 21:23  OrCAD Capture C..
aturo 8| anl_misc.clb 17/08/2009 17:41 QrCAD Capture C...
\B| anlg_dev.clb 17/08/2009 17:41 QrCAD Capture C... 1
._g 8] apex.olb 17/08/2009 17:41 OrCAD Capture C...
Equipo |Bl| apex_pwm.olb 17/08/2009 17:41 OrCAD Capture C.., i
_ F] . r
A
;d Mombre: analog.olb -
Tipo: [ Capture Library (" olb) +| [ Cancelar |
[] Abrir come archive de sélo lectura

Figura 11

De tota la llista que es troba en la carpeta “pspice”, triarem la llibreria “analog.olb” que
inclou, entre d’altres, els components passius com resisténcies o condensadors. Fixeu-vos
que després de seleccionar aquesta llibreria en el quadre “Part List:” hi ha aparegut tota
una llista de components entre els quals hi ha les resisténcies (R) i els condensadors (C).
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L’altra llibreria que també afegirem de la mateixa forma és “source.olb” que inclou els
diferents tipus de fonts que poden utilitzar-se.

Ara, primer afegirem la resisténcia R; al nostre esquematic. Per seleccionar I'element que
voleu afegir al circuit, heu de seleccionar primer la llibreria on es troba (ANALOG), heu de
seleccionar I'element (R) i heu de fer un “Return” per passar a la finestra de captura
d’esquematics.

HEN=N=RE) o QA A] @ BEaWEtQ ] L
i =} LA AA
Eoomnld e |

|
m=3m|
1

Packaging
Patisper Pka 1

o

VMY | Type Homogeneaus
-

O & a4 2 4 S ~[B]F]

)2 085 A% E

22

(ST =

e

1 item selected [ Part Ref:R? Part Valueilk ] Scale=100%  X=3.70 V=220

Figura 12

Per acabar heu de posicionar I'element en el lloc desitjat, heu de polsar el boté esquerre del
ratoli per fixar-lo i polsant el boté dret heu de triar “End Mode” o bé fer “Esc” per sortir.

Per defecte, el programa va numerant els components per ordre d’introduccié. Com que R;

ja ens va bé, no cal modificar-lo. El valor per defecte de les resistencies és de 1 kQ que
també és el que volem i, per tant, no cal modificar-lo.
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Figura 13

Procediu de la mateixa forma amb l'element C de la llibreria ANALOG per afegir el
condensador C;. Com que volem disposar-lo en vertical, abans de posicionar-lo, polsant el

7

botd dret del ratoli, triem I'opcid “Rotate”. També es pot fer rotar el component utilitzant la

lletra R del teclat.
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Figura 14
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La capacitat per defecte dels condensadors és de 1 nF. Per canviar-la per la capacitat
desitjada cal fer doble-click amb el bot6é esquerre sobre 1 nF i en la finestra de dialeg cal
canviar el valor a 10 nF com es mostra en la Figura 15.

) -
bl & - ] |
Font
Name: Yaluz Aiial 7 (defaul]
Vi Changs... Use Default
Display Format
Color
Do Mot Display _
® Velus Ori -
Name and Walue Ratation
Narme Orly ® 0 T
Both if alue Exists =g 270
[ ok [ Cancel | [ Hep
Figura 15

Noteu que per especificar el valor podem utilitzar una notacié cientifica que inclou un factor
d’escala designat per un simbol com es mostra en la Taula 1. Cal anar amb compte amb el
prefix M que significa “Mili” i que per especificar “Mega” cal utilitzar el prefix MEG (tingueu en
compte que el programa no diferencia entre majuscules i mindscules). Les unitats de la

variable, en aquest cas F de Farads, pot especificar-se o0 no ja que el programa ho tracta
igual.

Unit Name Symbol Exponential Form | Value
Femto F (or f) 1E-15 10"
Pico P (or p) 1E-12 10"
Nano N (or n) 1E-9 10°
Micro (u) U (or u) 1E-6 10°
Milli M (or m) 1E-3 10°
Kilo K (or k) 1E3 10°
Meg MEG (or meg) 1E6 10°
Giga G (org) 1E9 10°
Tera T (ort) 1E12 10"

Taula 1

El darrer element que hem d’afegir al circuit és la font de tensié sinusoidal. Cal procedir de la
mateixa forma que en els components anteriors perd seleccionant la font VSIN de la llibreria
SOURCE. Podem canviar el nom de la font fent doble-click sobre V1 i canviant-lo a Vi. Fent
doble-click sobre VAMPL s’ha d’especificar 1 V d’amplitud i fent doble-click sobre FREQ
s’ha d’especificar 1 kHz de freqliéncia. La VOFF s’ha d’especificar de 0 V que vol dir que no
hi ha desplagament de tensié continua.
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Figura 16

Per completar el circuit ja només queda connectar els diferents elements. Per fer-ho cal
seleccionar:

Place > Wire

O bé, heu de clickar Iicona L del ment Draw del marge dret de la pantalla. La connexio
entre dos terminals de components es fa situant el cursor sobre un d’ells, clickant el botd
esquerre i mantenint-lo polsat dibuixar la connexié fins el terminal de I'altre component. Feu
el mateix per afegir totes les connexions del circuit. Per sortir de Place Wire heu de polsar el
botd dret del ratoli i triar “End Wire” o bé fer “Esc”.

Si es vol modificar o suprimir algun component o punt del circuit es pot seleccionar amb el

botd dret del ratoli quedant ressaltat en color rosat. Amb el boté dret s’obre el menu que
permet fer les modificacions.
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Figura 17
Finalment 'esquematic queda com en la Figura 18.
o
Ay
Tk ‘
VOFF =0V N
VAMPL = 1V + 1
FREQ = 1kHz 10nF
=0 o
Figura 18

Per acabar la introduccié de I'esquematic del circuit que es vol simular, s’ha de salvar amb:

File > Save

O bé clickant la icona equivalent k=l de la barra Capture de la part superior de la pantalla.

Com es crea una simulacié i s’especifiquen el seus
parametres?

Un cop completat el circuit s’ha de configurar la simulacié. Cal seleccionar:

Pspice > New Simulation Profile

O bé clickar la icona equivalent de la barra Pspice de la part superior de la pantalla.
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Figura 19

En obrir-se la finestra de dialeg s’ha d’especificar el nom que vol donar-se a la simulacié. En
aquest cas li direm resposta temporal i clickarem “Create”.

New Simulation “ ==

Mame:

1esposta tempolal

Inkerit From;

Cra—

Root Schematic:  SCHEMATICT

Figura 120

Aquesta accié fa obrir la finestra de configuracid de la simulaci6. De moment ['Unic
parametre que modificarem és la durada de la simulaci6 i especificarem 5 ms a “Run to
time”. Tingueu en compte que es tracta d’'una simulacioé per veure 'evolucié temporal dels
senyals del circuit ja que “Analysis type” esta configurat com “Time Domain (Transient)”.
Per poder visualitzar 5 cicles dels senyals, a la freqtiéncia de 1 kHz, aixd resulta igual a

5 ms.
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Figura 21

Per tancar la configuracio de la simulacié només cal clickar a “Aceptar’.

Com s’executa la simulacio?

per executar la simulacié hem de seleccionar:

Pspice > Run

O bé clickar la icona equivalent @ e labarra Pspice de la part superior de la pantalla.
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(3.30, 2.90) I

<

Run PSpice simulation for active profile. 0 items selected

Figura 22

Scale=100%  X=060 ¥=000

En la part inferior de la pantalla hi apareix la finestra “Session Log” on van sortint els
missatges que ens informen de I'evolucié de la simulacio.
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Com es visualitzen els resultats de la simulacio?

L’execucié de la simulacid, si no hi ha hagut errors, obre automaticament la interficie de
visualitzacié com es mostra en la Figura 23.

B Eile Edit View race Plot Tools Window Help [ cadence - % X
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aRAD
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Time step = 7458608 Time = 5.000E-03 End= 6.000E03

Time= 5.000E-03 100% -/

Gi\Users\aturo\Ds

Figura 23

En aquesta pantalla podrem veure I'evolucié temporal de totes les variables del circuit i
inclis operacions matematiques fetes amb elles. Per afegir la visualitzacié d’una variable
hem de seleccionar:

Trace > Add Trace
O bé clickar la icona equivalent % del menu Pspice de la part superior de la pantalla.

Aquesta acci6 obre la finestra de dialeg que permet triar la variable que es vol visualitzar. La
primera variable que visualitzarem és la tensié d’entrada del circuit, és a dir, la tensié de la
font. Per aquest motiu seleccionarem de la llista “Simulation Output Variables” la variable
“V(Vi:+)" i fem “OK”.

Recordeu que totes les tensions estan referides al node de massa 0. La forma com
apareixen especificades en la llista de variables de sortida és donant el component i el
terminal que correspon al node del qual vol representar-se la seva tensio respecte a massa.
Per tant, “V(Vi:+)” es refereix a la tensio referida a massa que hi ha en el terminal + de la

font Vi.
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Figura 24

El resultat és el que apareix a la Figura 25.
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Sitnulation complete
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10 |

Figura 25

la visualitzacio de resultats?

Si ens fixem en la tensid visualitzada en la Figura 25 es veu que la seva forma apareix en
trams lineals. El motiu és que la simulacié no té suficients punts. Per solucionar-ho, hem de
modificar a la configuracié de la simulacié. Primer hem de tornar a la finestra principal i
seleccionar:

Pspice > Edit Simulation Profile
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O bé clickar la icona equivalent “2 del menu Pspice de la part superior de la pantalla. Ara
fixarem el pas maxim entre punts de la simulacio “Maximum step size” a 10 us la qual cosa
vol dir un minim de 100 punts per a cada cicle dels senyals. Clickem “Aceptar”.

Simulation Settings - resposta temporal

General | Analysis | Configuration Files | Options | Data Collection | Probe Window

Analysis type

‘ml Run ta time: Sms seconds [TSTOP]
Options Start saving data sfter: 0 seconds
=~ Transient options
Mortte Carlo/Worst Case Maximumn step sizes 10us seconds

Parametric Sweep

Temperature (Sweep)

Save Bias Point

Load Bias Point Fiun in resume mods T——
Output File Opti .

Save Check Points |w‘

Restart Simulation

Skip the initial transient bias point calculation [SKIPBF]

[ Aceptar | [ Cancelar | [ Awda |

Figura 26

Tornem a executar la simulacié amb “Pspice > Run” o bé clickant la icona equivalent ("}
Es torna a obrir la finestra de visualitzacio i procedim de la mateixa forma que en l'apartat
anterior per afegir el senyal d’entrada. Amb el mateix procediment afegim la tensio de
sortida, és a dir, la tensié en el condensador. Aquesta tensié correspon a la variable V(C1:2).

e Edit View Simulation Trace Dlot Tool Window Help [ cadence - %X

b~ B B = SCHEMATICTsposta tem (+)

QQaa Vi E X WEE WM

aRAD

Lol
Lelx
Lol

XValue

Time step = 75156-08  Time = 5.000E-03 End= 6.000E03

" Analysis {{Walch A Devices

Time= 5.000E-03 100% -/

Figura 27
En aquesta visualitzaciéo es pot apreciar que les dues senyals es superposen ja que, en

aquest cas, la frequéncia del senyal de 1 kHz és molt menor que la frequéncia de tall del
circuit RC que es comporta com un filtre passabaixes.
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Per veure que és el que succeeix quan la frequéncia del senyal d’entrada és més gran,
anirem a I'esquematic i farem doble-click sobre el parametre FREQ de la font i la canviarem

a 1 MHz. Noteu que per especificar el prefix Mega hem d'utilitzar MEG ja que en PSPICE
una M significa el prefix Mili.

Display Propertes NN =
Font
Name: FREQ Auial 7 [default)
Value:  [IIEERH Use Defaul
Display Farmat
Col
) Do Mot Display UD
> Vakue Oni .
@ Name and Value ——
) Name Only @0 180
_) Both if ¥alue Exists 90° Ering
[ ok [ Cancel | [ Hep
Figura 28

Com que s’ha canviat la freqiiéncia, per visualitzar el mateix nombre de cicles amb la
mateixa resolucié s’han de modificar els parametres de la simulacié. Per tant, des de la
finestra principal s’ha de seleccionar:

Pspice > Edit Simulation Profile

O bé clickar la icona equivalent del menu Pspice de la part superior de la pantalla.
Com que hem augmentat un factor per 1000 la freqliéncia, hem de dividir per la mateixa
quantitat la durada de la simulacio i el pas minim entre punts de la simulacié. Per tant, heu
de canviar aquests dos parametres i fer “Aceptar”.

Simulation Settings - resposta lempor_ @1
General | Analysis | Corfiguration Files | Options | Data Collection | Probe Window |
Analysis type:
Run to time: Sug seconds (TSTOP)
i | Options Start saving data siter. 0 seconds

Transient options
[ Monte Carlo/Worst Case Mawimum step size: 10ns seconds

|| Paremetric Sweep o ) !
[ Temperaturs (Swess) ] Skip the iniial ransient bias point caleulation (SKIPER)

] Save Bias Poirt

o e e e
tput File Opti
[ Save Check Foints utput File Options

|| Restart Simulation

[CAceptar | [ Cancelar | [ Apicar | [ Awda

Figura 29

Una altra questié que apareix a I'hora d’afegir la visualitzacié d’una tensié és la dificultat
d’identificar-la pel seu nom entre totes les variables. Una forma de facilitar la visualitzacio
dels senyals d’interés en el circuit és mitjancant I'is dels marcadors “Markers”. Per afegir un
marcador de tensid, des de la finestra principal hem de seleccionar:

Pspice > Markers > Voltage Level
O bé hem de clickar la icona equivalent B del menu Pspice de la part superior de la

pantalla i després arrossegar fins al marcador al node d’interés.
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Figura 30

| afegirem un marcador en cadascun dels dos nodes (d’entrada i de sortida) que ens
interessen. Per sortir d’aquest mode s’ha de fer, com sempre, clickant el bot6 dret del ratoli i
seleccionant “End Mode”.

R1
1K
2 \

vi
VOFF = 0V —= c1
VAMPL=1v  \~ 10nF
FREQ = 1MEGHz

0 -0

Figura 31

Tornem a executar la simulacié amb “Pspice > Run” o bé clickant la icona equivalent "}
Aquest cop, com que s’han definit els marcadors amb les variables d’interés, quan s’obre la
finestra de visualitzacio ja apareixen directament dibuixades.
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Figura 32

En aquesta visualitzaci6 es veu com la tensié de sortida esta atenuada i desfasada respecte
la tensié d’entrada, la qual cosa es logica degut a I'efecte passabaixes del circuit RC.

Com es salva i es recupera una simulacié?
Es aconsellable anar guardant les simulacions a mesura que es van executant: un cop
introduit 'esquematic, quan s’hagi configurat el perfil de simulacié i després d’executar la

simulacio. Per fer-ho només cal anar a “File > Save” o bé clickar sobre la icona &.

Per recuperar projectes o simulacions antigues, primer cal obrir el projecte després
d’arrencar el programa OrCad Capture:

File > Open > Project

| després heu de triar el projecte del qual es tracta dins de la llista de la finestra de dialeg.
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Figura 33

Un cop esta carregat el projecte, heu d’obrir 'esquematic anant a la pestanya File i després
de triar “Design Resources > Nom projecte.dsn > SCHEMATIC1 > PAGE1” heu de fer
doble click a PAGEA1.

A partir d’aquest punt podeu recuperar els perfils de les simulacions guardades en el
projecte i visualitzar els resultats de simulacions anteriors si les havieu guardat.

Exercicis

A partir d’aquest punt heu de continuar familiaritzant-vos amb el programa fent una série
d’exercicis que completen la simulacié d’aquest mateix circuit RC.

Exercici 1

Volem veure com es comporta el circuit RC quan el senyal d’entrada és quadrat i de 50 kHz.
Per fer aquesta simulacié cal canviar la font d’entrada a I'esquematic. Esborreu la font VSIN i
afegiu una font VPULSE amb els parametres que apareixen en la Figura 34. Podeu trobar
que significa cada parametre de la font en 'Annex que hi ha al final del document de la
Sessio 1.

PER
V2

Wi=1y L
V2 =1V L
TD = in= Wi | |
TR =1ns Vi | I
TF = ins I ! !
FW = 10us i e
FER = 20us ¢ TR PWTE

D

Figura 34
Ajusteu la configuracio de la simulacié i presenteu els resultats.

Exercici 2

Aquest exercici consisteix en tornar a veure com varia la tensié de sortida quan es canvia la
freqiéncia del senyal d’entrada . Ara, perd, visualitzareu al mateix temps els resultats amb
tres frequéncies diferents. Primer, el que heu de fer es replicar el circuit tres cops
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seleccionant tot el circuit amb el ratoli (ha de quedar tot el circuit marcat en rosat) i despres
utilitzant les opcions “Copy” i “Paste” del menu “Edit” de la part superior de la pantalla.

VOFF =0V
VAMPL = 1V
FREQ = 1kHz

VOFF = OV
VAMPL = 1V

VAMPL = 1V
FREQ = 100kHz

1w
V3
VOFF = OV
l
o

Figura 35

Fixeu-vos que el programa canvia automaticament els noms dels components per aque no
estiguin repetits.

Després heu de canviar la frequéncia de les fonts d’entrada dels circuits per especificar-les
en 1 kHz, 10 kHz i 100 kHz respectivament. Per acabar, executeu la simulacié, visualitzeu la
tensio de sortida i determineu la seva amplitud per a cada frequéncia.

Exercici 3

Volem veure la resposta freqlencial del circuit (en aquesta sessi®é només ens fixarem en
lamplitud), és a dir, la seva dependéncia en funcié de la freqiéncia. Recordeu que en
I'exercici anterior ja hem vist que, quan canviem la frequéncia de la font d’entrada, I'amplitud
de la tensié de sortida varia. Per tant, ara farem la simulacié del circuit per representar
directament com varia 'amplitud de la tensio de sortida en funcié de la freqiiéncia.

Per fer aquesta simulacié hem d’utilitzar un altre tipus d’analisi en la seva configuracio. Heu
de crear un altre perfil de simulacié amb “Pspice > New Simulation Profile” o bé clickant la

icona equivalent = del menu Pspice de la part superior de la pantalla. Heu de canviar el
tipus d’analisi a “AC Sweep/Noise” i els parametres que heu d’especificar sén els de la
Figura 35 (freqiiéncia inicial, frequéncia final, nombre de punts i tipus d’escombrat).
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Simulation Settings - resposta frequencia-

General | Andlysis | Corfiguration Files | Options | Data Collection | Frobe Window |

Analysis type:
AC Sweep/Noise -

Options

General Settings

[ Morte CarlosWorst Case
[]Parametric Sweep

[ Temperature (Sweep)

[ Save Bias Poirt
[ Load Bias Point

AC Sweep Typs
) Linear Star Frequencyr 100
@ Logaiithmic End Frequency:  10MEG

Paints/Decade: 1000

Maise Analysis

[] Enabled

Output File Options

[ Include detailed bias paint infarmation for nonlinear
controlled sources and semiconductors (0P

Aceptar Aplicar Ayuda

A més, abans d’executar la simulacio,

Figura 36

heu de canviar la font de tensi6é d’entrada ja que en

aquest analisi la font ha de ser del tipus VAC.

Feu aquesta simulacio i presenteu els resultats. A partir de la visualitzacidé, determineu quina

és la frequéncia de tall del circuit.

Exercici 4

Heu de repetir totes les simulacions que heu fet amb el circuit RC passabaixes (resposta
temporal amb senyals sinusoidals i quadrats i resposta frequencial), amb el circuit RC

passaaltes complementari que es representa en la Figura 37.

<
+
10nF
R1 \Y
1k Q ©
Figura 37

Heu de presentar els resultats de totes aquestes simulacions.
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Annex

L’OrCad Capture disposa de tres barres de menus amb icones per seleccionar directament a
les accions que es desitja realitzar. Aquests tres menus son: menu principal Capture, menu
Draw i menu Pspice. Apart I'eina de visualitzacioé de resultats Probe disposa també d’'unes
barres de menus.

A continuacié es detallen les opcions més importants de cadascun d’aquests menus que son
les que s'utilitzen més habitualment.

Barra de menu Capture

Eul—‘E@‘aéﬁﬂﬂ?»c-VS'N B8 A { = gt

La barra Capture proporciona un accés facil a les opcions més utilitzades del menu principal
del programa. En la taula seglent es detalla la funcié dels més importants.

lcon Name Description
L3 Mew Creaies a new document based on the active document.
document Equivalent to the New command on the File menu.
= Cipen Opens an existing document based on the active
document document. Equivalent to the Open command on the File menu.
| Save Saves the active schematic page or part. Equivalent to
document the Save command on the File menu.
Lk Print Prints the active schematic page or pant. Equivalent fo the
s Print command on the File menu.
2 Cutto Removes the selected object and places it on the
clipboard Clipboard. Equivalent to the Cut command on the Edit menu.
B Copy to Copies the selected object to the Cliphboard. Equivalent to
clipboard the Copy command on the Edit menu.
E"j Paste from | Pastes the contents of the Clipboard at the cursor.
clipboard Equivalent to the Paste command on the Edit menu.
Undo Undoes the last command performed. Equivalent to the
Undo command on the Edit menu.
Redo Redoes the last command performed. Equivalent to the
Redo command on the Edit menu.
Most Displays the most recently placed part name in the dropdown
45133« | recently list. Capture automatically adds part names as you select them from the
used Place Part dialog box. Select from the list to place parts again later.
¥ Zoom in FZooms in to present a closer, enlarged view. Equivalent to
the In command on the Zoom menu (on the Yiew menu).
(=} Zoom out Zooms out to present more of your document. Equivalent
to the Out command on the Zoom menu (on the Yiew menu).
A Zoom to Specifies an area of the schematic page or part to
region enlarge to fill the entire window. Equivalent to the Area
command on the Zoom menu (on the View menu).
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Barra de menu Draw

La barra Draw permet I'accés facil a les eines per dibuixar i especificar 'esquematic

b
dels circuits que es volen simular. Habitualment aquesta barra esta ancorada en el ..
marge dret de la pantalla. A continuacié es detallen les funcions més utilitzades. [,
r
‘='\_1/_\
L.
-
Tool Name Description N
[y Select Selects objects. This is the nomal mode. 3
Y
i_é Place part Selects parts from a library for placement. Equivalent to the ;
Part command on the Place menu. L/
il Place wire Draws wires. SHIFT allows any angle drawing. Equivalent to B
the Wire command on the Place menu.
ake Place net Flaces aliases on wires and buses. Equivalent to the Net Alias =
alias command on the Place menu.
' Place Flaces ground symhols. Equivalent fo the Ground command i
- ground on the Place menu. [
BL Place Places offpage connectors. Equivalent to the Off-Page Ix
: offpage Connector command on the Place menu. .
connector Iy
oy
o
e
T
I
3

o
oR

Barra de menu Pspice

ESCHEMATIU-Iesposta - (%) ) ® @

Aquesta barra de menus proporciona els enllagcos directes a les eines més habituals per
configurar i executar les simulacions PSpice. Aquesta barra apareix quan hi ha obert un
projecte que utilitza PSPICE. Les funcions més habituals es descriuen a continuacio.

Tool Name Description
s New simulation Creates a new simulation profile. Equivalent to the New
profile Simulation Profile command on the Pspice menu.
o), | BEdit simulation | Opens simulation profile for editing. Equivalent to the Edit
=1 profile Simulation Profile command on the Pspice menu.
[+ Run PSpice Funs PSpice simulation for active profile. Equivalent to the
Run Pspice command on the Pspice menu.
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WView simulation
results

Shows simulation results for the active profile. Equivalent to
the View Simulation Results command on the Pspice menu.

Place voltage

Places voltage/digital level markers. Equivalent to the Voltage

B &

marker Level command on the Markers sub-menu of the Pspice menu.

Place current Places marker showing current into a pin. Equivalent to the

marker Current Into Pin command on the Markers sub-menu of the
Pspice menu.

Enable bias Enables display of bias voltages. Equivalent to the Enable Bias

voltage display

Voltage Display command on the Bias Points sub-menu of the
Pspice menu.

ol
<

Toggle bias
voltage display

Toggles display of voltage bias point value for selection.
Equivalent to the Toggle Selected Bias Voltage Display
command on the Bias Points sub-menu of the Pspice menu.

Enable bias
current display

Enables display of bias currents. Equivalent to the Enable bias
current display command on the Bias Points sub-menu of the
Pspice menu.

—eud
fu

Toggle bias
current

Toggles display of current bias point value for selection.
Equivalent to the Toggle Selected Bias Current Display
command on the Bias Points sub-menu of the Pspice menu.

Barres de menus del Probe

Després de I'execucio de la simulacid, s’obre la finestra de presentacio dels resultats Probe.
En aquesta finestra es disposa de una série de barres de menus que faciliten I'accés a les
diferents eines com s’explica en les taules segulents.

U > > E’:‘, = SCHEMATICT-resposta tem 6
Tool Name Description
File Toolbar
= Open Opens an exisiing document based on the active
document document. Equivalent to the Open command on the File menu.
= Save Saves the active schematic page or part. Equivalent to
document the Save command on the File menu. [This may be blanked ]
p=y Print Prints the acfive schematic page or part. Equivalent o the
Print command on the File menu.
Simulate Toolbar
in PSpice
Run Runs the current simulation. Equivalent to the Run

command on the Simulation menu.
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Probe toolbar in

PSpice
] Zoom in Zooms in on a specified point. Equivalent to the In command on the
Zoom menu (on the View menu).

=, Zoom out Zooms out from a specified point. Equivalent fo the Qut command on
the Zoom menu {on the View menu).

Q. Zoom area Zooms in an a selected area of a graph. Equivalent to the Area
command on the Zoom menu (on the View menu).

& Zoom fit Zooms to show all traces and labels. Equivalent to the Fit command on
the Zoom menu {on the View menu). [Note: Returns fo original graphs.]

Add frace COpens the Add Traces dialog box, which you use to add a trace (or

b traces) to a selected plot. Equivalent to the Add Trace command on
the Trace menu.

ABC | Textlabel Opens the Text Label dialog box, which you use to add a text labelto a

abe graph. Equivalent to the Text command on the Label menu {on the Plot
menu).

L Mark data points | Marks data points on analog traces. Equivalent to selecting the Mark
Data Points option in the Probe Options dialog box (accessed by
choosing the Options command on the Tools menu).

Toggle cursor Toggles the display of the Probe cursor on and off. Equivalent to the

Display command on the Cursor menu (on the Trace menu).
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